Turbo-R changing default keyboard characters

By Sacking2005

Supporter (4)

Sacking2005's picture

10-01-2018, 15:28

Hello All. I'm currently having a problem with my Turbo-R. The character set seems to have defaulted from English alphabet to a mix of Japanese characters when I hit certain buttons and symbols when I hit others. Power cycling the unit doesn't seem to have changed anything. I have tested this in both MSXDOS and BASIC, the result is the same. Is there anyway to change the default character set back to English? Any assistance would be greatly appreciated!

Login or register to post comments

By Wolverine_nl

Paladin (999)

Wolverine_nl's picture

10-01-2018, 16:36

Is the Kan-lock LED active? Like the Caps-lock this is for KANJI (not to sure anymore, never use it)
Maybe someone knows of a certain setting in the RTC chip might have caused this.
Are you using batteries for the clock chip?

By Manuel

Ascended (14891)

Manuel's picture

10-01-2018, 18:55

Can you make a video of what exactly is happening?

By Sacking2005

Supporter (4)

Sacking2005's picture

11-01-2018, 15:55

Alright some new information.
Firstly Im not using any batteries for the clock chip, and Im not sure if Kan-lock is enabled

Here is a photo of the indicator lights that are lit up whenever the Turbo-R is in BASIC.

Here is a photo of the button immediately to the left of the spacebar that when pressed and held in allows me to type English characters.

Lastly here is a video showing key presses with and without the button held in.

Again thanks for all the assistance. I greatly appreciate it!

By Sacking2005

Supporter (4)

Sacking2005's picture

11-01-2018, 16:15

Heres a link to a video of what is happening. when I press and hold in the key to the left of the spacebar it changes the character set to english, but only as long as I hold in the key


By Meits

Scribe (5226)

Meits's picture

11-01-2018, 16:15

That's odd... The keys left and right to the space bar are yes/no buttons in the built in word processor.
The key left to the pause is what europeans know as the code button, but in stead of just code, it works like the caps lock, code-lock if you wish, where our code works like the shift: code on/off, only on turbo R code is called kana (iirc).
The yes (or no) button of the word processor should not have any effect on the keys being pressed.

By Grauw

Enlighted (7662)

Grauw's picture

11-01-2018, 17:22

Have you tried carefully unplugging and replugging the keyboard flat cables? Maybe jiggling them a bit?


Enlighted (5077)

NYYRIKKI's picture

11-01-2018, 20:05

@Sacking2005 It seems that your GRPH-key is somehow locked down... and the key on right of it seems to affect to the functionality somehow... Grauw's idea of unplugging and replugging the keyboard cables might not be a bad idea as well as making sure there is no dirt between the keyboard membranes.

My MSX profile