Turbo-R not starting

Page 3/3
1 | 2 |

By Jipe

Paragon (1319)

Jipe's picture

01-07-2017, 19:36

damn , turbo-R signals are not buffering direct to S1990 or T9769
VDP have a quartz just for it
don't plug the power supply and check a "court-circuit" in slot between 2 pins adress or datas with the multimeter in ohm

By janvv

Resident (39)

janvv's picture

02-07-2017, 12:15

I can't find a short-circuit. The lowest resistance I can find between two pins is 6000KOhm

By Grauw

Enlighted (7413)

Grauw's picture

09-07-2017, 23:34

Hey janvv, how fares your turboR?

Just wanted to say that a couple of years ago my CX5M-II broke down and the community here was very helpful, if you’re not too scared of a soldering iron. Maxis walked me through it wonderfully, and with the help of a newly purchased logic probe and some smart debugging suggestions, I was able to find the problem. It was quite a nice and educational experience actually! I noticed a few months back that my Philips NMS8245 does not boot up anymore, I should start a new thread about that! :D

(p.s. When I was a kid I did break two slot expanders and a Contra cartridge plugging them in while the MSX was on, my father wasn’t too happy about that :D. The MSX survived though, luckily, and one of the expanders was repaired and still in use today. The Contra cartridge however, the SCC sounds very… odd.)

By Alexey

Guardian (1663)

Alexey's picture

10-07-2017, 11:38

We really need a diagnostics cartridge and also the possibility to put the diagnostics ROM (inside EEPROM chip) into the physical socket on the board instead of MSX BIOS...

By Meits

Scribe (5122)

Meits's picture

10-07-2017, 11:38

I am confident janvv can do it with help from the community. I mean, he coded Shrines of Enigma. The man got some well organized brains Smile

By janvv

Resident (39)

janvv's picture

21-07-2017, 21:41

Thanks everyone! Tbh I am assuming at this point that something is seriously wrong, and I'm saving up for a new Turbo R :/

Maybe one day I can bring it to an MSX fair and someone with the right skills and equipment can have a look at it for me.

By Meits

Scribe (5122)

Meits's picture

22-07-2017, 00:59

Jan, check your facebook. There's a message pending to be accepted by you.

By janvv

Resident (39)

janvv's picture

22-07-2017, 08:41

Meits: I checked buy can't see anything?

By Meits

Scribe (5122)

Meits's picture

22-07-2017, 11:29

How odd. You probably have set up your facebook so it doesn't accept messages from non-friends. It has left my computer.

Hindsight: Oh, indeed you don't have a public e-mail address in your profile, but I totally overlooked the contact tab. You'll have your message Wink

By Grauw

Enlighted (7413)

Grauw's picture

26-05-2018, 01:19

Grauw wrote:

I noticed a few months back that my Philips NMS8245 does not boot up anymore

Heh, I took my logic probe out of storage and got all ready to fix it, and then I plugged it in and everything worked just fine. Why it didn’t work before, no clue Question, but I’m glad it’s ok. Since I was going to open it up anyway, I took the opportunity to resolder the SCART contacts since it was a bit sensitive to jiggling, and removed the battery. The disk drive also doesn’t work, belt worn down I guess, but I didn’t investigate further.

Page 3/3
1 | 2 |
My MSX profile