Weird time issue

By Phantom

Supporter (15)

Phantom's picture

20-06-2007, 01:14

I recently replaced the battery of my NMS 8250 to get the clock working again. Unfortunately it's still not working properly. When the MSX is powered off, time is kept properly. However, when it's powered on, the clock seems to be 'paused' for a short period several times a minute, causing it to lag behind by several seconds per minute.

Does anyone have any idea what might be causing this?

Login or register to post comments

By Omega

Master (230)

Omega's picture

10-06-2013, 12:28

I'm having almost the exact same issue; RTC clock runs perfectly when NMS 8250 is turned off, but it does not run at all when it is turned on.. Not at all means get time a$: ? a$ will always return the same value.

My battery has already been replaced with a fresh one a couple of years ago so I don't think that's the problem. But I have to do some measurements first..

By Omega

Master (230)

Omega's picture

08-07-2013, 12:31

So, after testing everything I could think of, problem solved Hannibal

It turned out to be chrystal X102. Replace with a 32.768kHz 3mmx8mm chrystal. Example: eijlander.nl E 1,77

See the service manual, page 13.

Thanks to Nyyrikki for the test method. How to test RTC clock frequency Without a frequency counter or oscilloscope:

Quote:

You can test the RTC functionality quite easily if you output 1Hz test signal out to ALARM... First disable alarm (8 -> register #D) and then enable test signal ( 4 -> register #F) Use multimeter to measure ALARM pin (15) This is inverted open drain output.

So, out &hb4,&hd:out &hb5,8 and out &hb4,&hf:out&hb5,4. Remove pull up resistor R145 temporarily and measure. The multimeter should show a 1Hz alternating signal somewhere between 0v and 5v (depending on multimeter speed!) when powered on. In my case, it showed a steady 0v when on, and it started alternating when powering the MSX off. If it is not alternating or at a different frequency (faster..slower) the RTC is not getting a proper 32.768kHz clock signal.

My RTC is ticking again like it was 1986 :)
Tristan