Yamaha CX-11 upgrade to MSX2

Page 4/4
1 | 2 | 3 |

By Alexandre_Taito

Champion (325)

Alexandre_Taito's picture

24-07-2018, 07:24

NYYRIKKI wrote:
Alexandre_Taito wrote:

The problem was with the bios I had with the RTC patch. It was from an european computer, and without the correct keyboard map.

This sounds a bit weird, but I'm still interested. I hope you can explain...
The keyboard layout is in the Main-ROM (that includes BIOS) ... All of the RTC stuff is in SUBROM. They should not have that direct relationship... Was there something wrong of what I told you? Did you get it to boot 50Hz, 60Hz or on demand?
(unfortunately I have bit of a language problem with your blog)

No problem, I'm here to explain Smile

When I began modding this CX-11, I had a generic BIOS/SUB I use in the computers I mod to 2.0. This generic bios makes me be sure the conversion worked. I don't know where this bios came from, but it is from an european computer, 50hz, no memory count on BASIC. Also, the keyboard map had some keys changed in relation to CX11.

I had my YIS503/II BIOS on file, but it needed the RTC. The YIS bios maps perfectly to this computer, because the keyboard is the same, it is a japanese (with kanji) bios and 60Hz.

So, L_Oliveira helped me to patch the sub-rom to ignore the missing RTC, so I can use the YIS BIOS and everything fits. Keyboard works OK, Kanji characteres/keyboard mode are there, computer running in 60Hz mode and etc.

If you cannot understand something I say, please ask me to clarify Smile

Thanks!

By mohai

Paladin (841)

mohai's picture

24-07-2018, 19:59

Alexandre_Taito wrote:

Hi All!
I'm trying to upgrade a CX-11 to MSX2. I know it is hard without the service manual, but I'm trying.
In my head, the steps are:
- Upgrade VRAM to 128K (a pair of 4464 on top of the 4464 pair, pin 16 of the top memories connected to pin 60 of VDP, CAS1)
- MSX 2.0 MAIN ROM (without RTC and F4 register code) on place of MSX1 MAIN ROM
- MSX 2.0 SUB-ROM in slot, CE/OE connected to /SLTSEL

It **should** work. But it isn't.
Did I miss something?
Thanks!
Alexandre

I think there is a little design error:
/SLTSEL cannot be tied to both /CE and /OE, as you will select EPROM chip to be read, even if MSX is writing to that slot, so databus will go to an undesirable state.

By NYYRIKKI

Enlighted (5402)

NYYRIKKI's picture

25-07-2018, 00:21

mohai wrote:

I think there is a little design error:
/SLTSEL cannot be tied to both /CE and /OE, as you will select EPROM chip to be read, even if MSX is writing to that slot, so databus will go to an undesirable state.

I don't know why, but I must say I feel a bit invisible/ignored in general. I guess I'm happy though that we have a nice new MSX2 around!

By Alexandre_Taito

Champion (325)

Alexandre_Taito's picture

25-07-2018, 10:09

NYYRIKKI wrote:
mohai wrote:

I think there is a little design error:
/SLTSEL cannot be tied to both /CE and /OE, as you will select EPROM chip to be read, even if MSX is writing to that slot, so databus will go to an undesirable state.

I don't know why, but I must say I feel a bit invisible/ignored in general. I guess I'm happy though that we have a nice new MSX2 around!

Hey, I followed your advise and connected the EPROM as you said. You haven't been ignored Smile Thanks for your advice! Big smile I'm always learning...

By mohai

Paladin (841)

mohai's picture

25-07-2018, 16:07

NYYRIKKI wrote:
mohai wrote:

I think there is a little design error:
/SLTSEL cannot be tied to both /CE and /OE, as you will select EPROM chip to be read, even if MSX is writing to that slot, so databus will go to an undesirable state.

I don't know why, but I must say I feel a bit invisible/ignored in general. I guess I'm happy though that we have a nice new MSX2 around!

Shocked! Oops ! I think I missed your post before.

Page 4/4
1 | 2 | 3 |