New PC

By djh1697

Paragon (1409)

djh1697's picture

31-01-2017, 14:23

Wow! I just got a new motherboard i3 6700, with a 256Gb SSD. I can now run BlueMSX as a TurboR fully expanded without any timing delays - lovely!! Penguin Adventure @ 60Hz

Login or register to post comments

By Rataplan

Master (214)

Rataplan's picture

31-01-2017, 14:37

I've got the same CPU in my arcade-cab, but indeed sometimes, with all utter respect I have for all emulator developers, I wonder how some CPU's / systems are so slow to emulate. Running Playstation 2 games at full speed has never been a problem, even on my previous system. But indeed, BlueMSX in fullscreen has always been an issue for me too. Never tried that on my cab though.

By Manuel

Ascended (15691)

Manuel's picture

01-02-2017, 07:42

Did you also try other MSX emulators to compare?

You really shouldn't need a big PC to run blueMSX, by the way, so something's wrong somewhere.

By syn

Paragon (1920)

syn's picture

01-02-2017, 09:51

I feel openMSX is more sensitive /uses more cpu resources than blueMSX. While I can run blueMSX fine, often I will get stuttering sound if I have too many other programs open. This has always been this way (different pcs/installs).

By djh1697

Paragon (1409)

djh1697's picture

01-02-2017, 10:14

@Manuel No, I didn't try other emulators. I said in my post that I ran as a TurboR fully expanded, and in full screen mode! I had no issues previously running an expanded MSX2 on blueMSX.

By ren

Paragon (1219)

ren's picture

01-02-2017, 10:59

I do have a tip for Windows users (works for Win 7 anyway): disabling desktop composition can improve things, and can make the difference between lag/stutter or not.
This applies to windowed & windowed FS modes (I do believe blueMSX uses 'native' FS though.)
This can be done via the application's Compatibility settings (32-bit apps only).
Otherwise (for 64-bit apps as well): net stop uxsms. Or hack the registry Wink

Power saving settings can also have an impact, in my situation, when optimal performance is desired (esp. when working with real-time data (A/V) streams), it helps to set Minimum processor state to 70% (or higher) (or just use the 'High performance' profile).
See e.g. DPC Latency Checker.

Then there's the BIOS settings (Power Management). I've read some stuff that enabling or, the opposite, disabling (depending on your system) the High Precision Event Timer (HPET) can differ (played with that myself, but reverted back in the end, not sure if it was better/worse. In fact I had issues with a drifting system clock, turns out that was due to Windows' Power Saving settings (and/or perhaps mobo age / a mobo issue?) - I now run with 70% CPU by default.) Search e.g. for HPET performance (at your own peril ;))

By ren

Paragon (1219)

ren's picture

01-02-2017, 14:43

+ you could try to set the emu process priority to High (CPU Priority Shortcut for a Program [eightforums.com])

By karloch

Prophet (2059)

karloch's picture

01-02-2017, 18:36

openMSX uses as much resources as you demand. If you just ask for MSX1 with SCC, it will run at full speed even in a 17 years old ARM at 200 MHz Smile Take a look here.

By djh1697

Paragon (1409)

djh1697's picture

02-02-2017, 00:07

BlueMSX has a facility to boost the priority in the settings

By ren

Paragon (1219)

ren's picture

02-02-2017, 10:40

Supplementary to my last comment: there are some handy tools (raymond.cc) to set a process's priority permanently (handy e.g. for openmsx.exe that get's invoked via Catapult).

@djh1697 That's true, it will set the priority to Above Normal. (So you can boost it a little more if you'd want to..)