ALTGR not working under Windows and a question about ALT Codes in console.

Page 1/3
| 2 | 3

By DRomero

Expert (89)

DRomero's picture

29-01-2019, 20:48

Hello, i know it's an old Windows issue, but still...
Any way can i type the Yen symbol in a openMSX TurboR GT machine? I have tried everything, but nothing works.

Not only '¥', but neither '[' or ']'. My keyboard is an spanish QWERTY, and ALT GR do not work on openMSX in Windows.

It whould be useful if the console command could accept ALT Codes, like the pressing of ALT+0165 so we can use the "type" command in the console to print it in the MSX screen.

This could be used in conjuction with phisical/logical external key macros that some keyboards have.

Thanks.

Login or register to post comments

By Manuel

Ascended (15359)

Manuel's picture

29-01-2019, 22:50

Try \ to get a Yen... On a Japanese MSX, there is no \ symbol, as it was replaced by a Yen symbol.

For the other issues you could try the latest development build. Maybe it works better? Please report!

If you want to use special stuff to type into the MSX, you can put it in a file and use the type_from_file command in the console to type the stuff from the file into the MSX.

By DRomero

Expert (89)

DRomero's picture

30-01-2019, 05:38

Pressing \ on a spanish qwerty keyboard dosen't work to get the Yen in japanese MSXs, not can i get [ or ]...

I will try reading from file as you said and creating some key macros to get arround the AltGr bug in Windows.

Thanks.

By Manuel

Ascended (15359)

Manuel's picture

30-01-2019, 07:33

Please also try the latest development build from http://openmsx.fixato.net

By DRomero

Expert (89)

DRomero's picture

01-02-2019, 20:38

Thanks Manuel, but the same issue exists with the latest development build from fixato.

KANA seems HARDCODED to AltGr it seems. Can i ask why? By keyboard position maybe? It seem's the worst choice for the KANA key ever, let AltGr alone please hehehe. AltGr is used to type |, @, #, ~, [, ], { and } on the host machine, that key should be free from binds.

I tried to change the key from KANA (AltGr) to another one but it only seems to duplicate it, the original is still there...

One last question please, this is only an example... Can i bind ')' character to 'L' key?

')' is row 0, bit 0 so it equals to: "0 0x01" and SHIFT is row 6 bit 0 = "6 0x01"

I tried in the console with, but i get an error...

bind L "keymatrixdown 6 0x01; keymatrixdown 0 0x01"
bind L,release "keymatrixup 6 0x01; keymatrixup 0 0x01"

Thanks Manuel.

By Manuel

Ascended (15359)

Manuel's picture

02-02-2019, 13:12

Did you try the setting "kbd_host_kana_code_key"? It defaults to "RALT", but you probably want to map it to something else.

What error do you get with that bind command? It works fine here.

You can also try: bind F6 "type )". That works also here.

I can only test on Linux, but that shouldn't matter much. Also, I have a US QWERTY, so I don't even have an AltGr (just Left ALT).

By DRomero

Expert (89)

DRomero's picture

03-02-2019, 00:31

Yes, i have tried already the kbd_host_kana_code_key command, as i said in the post above it seems hardlocked to AltGr.

set kbd_host_kana_code_key RCTRL -> Now i have TWO Kana keys, AltGr & RCtrl.
set kbd_host_kana_code_key F7 -> Dosen't work, Kana still bound to RCTRL, F7 does nothing.
set kbd_host_kana_code_key PAGEUP -> Dosen't work, Kana still bound to RCTRL, PAGEUP does nothing.

So no matter what keys i try to bind to Kana it dosen't work or i end with duplicate Kana keys, AltGr is ALWAYS bound to Kana, no matter what, maybe i'm doing something wrong.

Now suposse i want to type the '@' character on the MSX... MSX TurboR machine has is own key for it (right on 'P') but at least in the spanish PC keyboard we have to press AltGr+2 for it to show that symbol.

'[' and ']' has their own keys on MSX Turbo machines but on the PC we have to press AltGr'[' and AltGr+].

Now these key combinations will never work in openMSX becasue Kana key seems hardcoded to AltGr in Windows.

I was trying to say, it would be usefull if i can bind for example MSX '@' to WindowsPC 'AltGr'+'2', keys like F6,PGUP, MENU, etc are not usefull for nomal typewritting those symbols.

Can i bind a combination of PC keys like the modifiers SHIFT or AltGr + normal keys to a MSX key for example?

You have to excuse me if i don't explain my self clearly, english is not my natural language, hope i have made my questions clear now.

Thanks.

By hit9918

Prophet (2853)

hit9918's picture

03-02-2019, 02:34

when I press ALT GR and A, I get the same chr$(1) as if I pressed CTRL + A!
in kbd_mapping_mode = key and character same thing

when I use alt gr in the F10 shell then all those alt gr letters work
it is not like the GL SDL can't do it

By rderooy

Hero (517)

rderooy's picture

03-02-2019, 11:37

Manuel wrote:

I can only test on Linux, but that shouldn't matter much. Also, I have a US QWERTY, so I don't even have an AltGr (just Left ALT).

FYI, you should be able to select a "US International with Dead keys" option. That will give you a working AltGr. It also means you can type accented letters. On the other hand it is quite annoying when programming as you need to hit some keys twice to get the character, like the single and double quote keys. But you can always set it up as a second keyboard layout and switch between them when needed.

Personally, I have the "US Int. with Euro key on 5" normally set as my primary keyboard layout, which also gives you a working AltGr.

By Meits

Scribe (5373)

Meits's picture

03-02-2019, 11:51

You can use ctrl+left alt as altgr as well. But still some keys need to be remapped. I've to get the $ working again on my .no keyboard. I would've liked it to work out of the box.

By NYYRIKKI

Enlighted (5268)

NYYRIKKI's picture

03-02-2019, 12:02

I just wanted to say that I can feel you pain... I've been in this exactly same situation for years with my Finnish keyboard.

I've learned to live with it by using kbd_mapping_mode=KEY... This way on tR I get "[" by pressing "¨/^" on my keyboard, "[" by pressing "§/½" and "¥" by pressing "'/*"-key.

This is far from optimal, but it is possible to live with it.

Page 1/3
| 2 | 3