Any way to easily "find" the debuggable viewer-window again?

Page 2/2
1 |

By Bengalack

Master (222)

Bengalack's picture

08-11-2020, 19:14

@Manuel I managed to dock it now, by dragging the text with the ":" Smile Thanks for the tip. As well as the video from @FiXato!

But there seems to be some bugs related to it. As you can see from the screenshot (the dropdown shows two places). The scroll-slider doesn't work correctly either.

But: I tested this, as well, in the version provided by FiXato, and in that version everything works as expected.

By FiXato

Scribe (1641)

FiXato's picture

08-11-2020, 19:22

Good to hear Bengalack Smile
I'll tweak the menu a bit so it goes in a 'windows' menu of its own, and disable it when there are no floating widgets, and post an updated one here afterwards.
Once wouter has reviewed the code, I'll see if I can update the version number and perhaps Niek can provide us with a new macOS build too.

By Bengalack

Master (222)

Bengalack's picture

08-11-2020, 19:24

BTW. Does anyone have a tip on how to get back some gray dockable area once you have detached all widgets? The code view now expanded across the full window, and floating windows wont attach at any place anymore. :-O

By Sandy Brand

Master (199)

Sandy Brand's picture

08-11-2020, 19:53

Yeah the debugger could definitely use some love Smile

@Bengalack:
I've ran into this annoying issue myself a couple of times and there seems to be no way to revert this.

What works for me, is to close the debugger and then manually delete the following registry keys:
Computer\HKEY_CURRENT_USER\SOFTWARE\openMSX\debugger\Layout\WidgetLayout
Computer\HKEY_CURRENT_USER\SOFTWARE\openMSX\debugger\Layout\WindowGeometry

This will basically hard revert the layout of the dialog to its defaults and have everything docked into place again.

By Manuel

Ascended (17078)

Manuel's picture

08-11-2020, 21:10

I fixed the following easy-to-fix issues:

sd_snatcher wrote:
  • The VDP R#17 auto-increment bit description is inverted
  • The VDP R#25 waitstate bit description is inverted
  • The VDP R#0 DG bit description only says "DG explained" instead of "Colorbus set for output" and "Colorbus set for input"
  • The mouse/light-pen bits have no description at all

As for the other issues: no idea how to fix these... The illegible stuff isn't reproducible on Linux, so it's hard to try and fix that for me.

By Bengalack

Master (222)

Bengalack's picture

08-11-2020, 22:38

Sandy Brand wrote:

What works for me, is to close the debugger and then manually delete the following registry keys:

Thanks Sandy - I'm back to normal again :-)

@FiXato - Thumbs up for the suggested tweaks!

By sd_snatcher

Prophet (3367)

sd_snatcher's picture

08-11-2020, 22:44

Manuel wrote:

I fixed the following easy-to-fix issues:

Easy or not, your fixes are much welcome! Thanks! Big smile

Page 2/2
1 |