Aspect Ratio - full screen mode

By Marcelo_Zoffy

Supporter (16)

Marcelo_Zoffy's picture

08-03-2013, 17:01

Hi,
Please, sorry my bad English.
I have a question about full screen mode. How can I maintain the aspect ratio on widescreen monitors?
I would like to configure OpenMSX to put black borders (even better if I can choose borders color ;-) ) on both side of the screen and maintain the 4:3 aspect.
I tried horizontal_stretch and display_deform, but no success.

Thank you!

Login or register to post comments

By GhostwriterP

Champion (511)

GhostwriterP's picture

08-03-2013, 20:38

This reminds me of the time of the first wide screen TV´s and people just watched everything stretched, I could never understand that... good thing there is meisei Wink

By syn

Paragon (1920)

syn's picture

08-03-2013, 21:34

It sounds like your monitor is automatically stretching it. Since I get 4:3 in openmsx in default settings

By Marcelo_Zoffy

Supporter (16)

Marcelo_Zoffy's picture

09-03-2013, 00:20

Thank you for the answers.
When I run OpenMSX in normal mode, the aspect is correct, the problem occurs when I run in full screen mode.
If I'm not wrong, OpenMSX for Android have an option to fix this problem, but I can't find nothing similar to Linux or Windows versions.

Thank you!

By Philip

Champion (371)

Philip's picture

09-03-2013, 10:06

I used to have this problem with my netbook with intel video running linux.
I was able to fix it with this: xrandr --output LVDS1 --set "scaling mode" "Full aspect"
However nowadays with newer linuxes I think they changed the default as I never have to run this anymore

By Marq

Champion (386)

Marq's picture

09-03-2013, 12:07

If you have an Nvidia graphics card and use Linux (probably something similar under Windoze) go to the Nvidia X Server Settings (nvidia-settings) and then under GPU 0 find your display, probably DFP-0. Turn on "Force full GPU scaling" and select "Aspect ratio scaled".

By Manuel

Ascended (15695)

Manuel's picture

09-03-2013, 14:32

Yep, change it in the monitor or GPU settings for now, as already explained.

By Marcelo_Zoffy

Supporter (16)

Marcelo_Zoffy's picture

09-03-2013, 18:44

Hi folks, thank you for all answers.
@Marq, your solution worked. Thank you so much.

By Manuel

Ascended (15695)

Manuel's picture

13-03-2019, 13:16

If you try the latest development build, this issue is now also fixed/improved, without having to use these settings. Full screen is now scaled by openMSX.