Disk drive for MSX1 in openmsx

Page 2/4
1 | | 3 | 4

By Shinobi

Resident (52)

Shinobi's picture

06-02-2018, 13:59

When I added the Disk drive ROM files to "systemroms" folder, the emulator recognized the disk drive by showing MSX Disk BASIC, but when loading files it showed "Disk Offline".

When Moving Disk Drive ROMs to "extensions", the disk drive worked ok.

No problem, may be I was not clear in my explaination.

By Manuel

Ascended (14780)

Manuel's picture

06-02-2018, 23:30

OK, then I did understand you correctly. So you already had the official disk ROM installed in your systemROMs folder and openMSX didn't give any error. But the MSX gave a Disk offline error when using it. This is strange, as this worked fine when I tried it on my PC here. The disk ROM you used originally should have worked.

So now to find out why it didn't work... which openMSX version were you using?

The simplest explanation: you may have thought you put a valid disk image in the emulated disk drive, but there wasn't any in...

By eimaster

Master (218)

eimaster's picture

07-02-2018, 03:14

Shinobi wrote:

If you have the ROM file for the Mitsubishi drive you mentioned, can you upload it to me?

I'll compress my extensions folder and put it in my google drive or dropbox acounts then I'll give you the link so you can download it, extract it, and keep it so you may find any missing file in it.

By Manuel

Ascended (14780)

Manuel's picture

07-02-2018, 09:34

There is no missing file, otherwise openMSX would have given an error. If you got disk BASIC and no openMSX error, the intended BIOS ROM was loaded. And that one works fine on my system here. Can you try again after removing the file from the extensions folder?

By Shinobi

Resident (52)

Shinobi's picture

09-02-2018, 22:49

I'll be very appreciated eimaster. Thank you.

By Shinobi

Resident (52)

Shinobi's picture

09-02-2018, 22:54

I tried it, I must put the ROM in extensions folder. I think Raspberry pi version is different. The version is openMSX 0.13.0 for Raspberry Pi.
Downloaded from:
http://misapuntesde.com/post.php?id=748

By Manuel

Ascended (14780)

Manuel's picture

09-02-2018, 22:54

I strongly recommend to put your ROM files in the systemroms folder... Not in the extensions folder

By Shinobi

Resident (52)

Shinobi's picture

10-02-2018, 13:51

It didn't work.
It works only when putting them in extensions folder.

Machine ROMs, I put them in systemroms folder. works OK
Disk Drive ROMs, I put them in extensions folder. works OK

By Manuel

Ascended (14780)

Manuel's picture

10-02-2018, 18:17

What do you mean by "it didn't work" ? What exactly did you try and what happened exactly?

Putting ROMs in the extensions folder means that you are overriding the ROM file that is specified in the configuration file. That specification file contains a checksum of a ROM that is known to be correct for that hardware.

By Shinobi

Resident (52)

Shinobi's picture

10-02-2018, 22:22

I wrote it in a previous post:

When I added the Disk drive ROM files to "systemroms" folder, the emulator recognized the disk drive by showing MSX Disk BASIC, but when loading files it showed "Disk Offline".

When Moving Disk Drive ROMs to "extensions", the disk drive worked ok.

Page 2/4
1 | | 3 | 4
My MSX profile