Keyboard issue in OpenMSX

By rolandve

Expert (113)

rolandve's picture

24-05-2016, 14:00

I run in to a problem that might be a bug. When I start my piece of test code

10 screen 2
20 print "Hello Wo

I will not reach the end of the line because openMSX starts to insert ' characters (in Basic) or " (in MSX-DOS 2) and it doesn't stop. This does not happen on my real machine. It happens with the machines I tested in openMSX (NMS8250, Toshiba HX-10).

It seems easy to reproduce:
- Start machine to basic
- type "
watch

Is this a problem on my specific build or is this a generic problem?

Login or register to post comments

By turbor

Champion (428)

turbor's picture

24-05-2016, 20:07

We need a little more info here, before we might be able to help you. Info like:
- Which operating system
- Your keyboard layout
- The version of openMSX

Most likely tough, the issue will be located in the SDL routines that we use to read out the keyboard.
Other things that might have an impact is the emulation speed. If you run this on underpowered hardware it might be that the somewhere the key-up event gets lost, that way in the emulated MSX the key remains pressed down, and the MSX Basic will start the autorepeat of that key automatically after a while.

Depending on your keyboard the emulator tries to smartly remap some inputs to the needed combination of MSX keys to produce the some characters in the emulated MSX, in which case the same key-up might be impacted.

By Manuel

Ascended (15839)

Manuel's picture

24-05-2016, 21:47

I guess you have a "US International" like keyboard setting (which has a composition feature, if you first type " and than e.g. an a, you get an ä). If you set it to normal "US", which does not have this feature, it will work fine. It's a limitation in SDL, I guess.

By rolandve

Expert (113)

rolandve's picture

25-05-2016, 07:38

Yep, international was the issue. Thanks!

By Francisco Gálvez

Resident (33)

Francisco Gálvez's picture

03-06-2016, 17:45

I got the same issue. Crying
OpenMSX ver: 0.10.0
SO: Xubuntu 14.10
Hard: laptop Toshiba satellite pro 200 , Centrino DUO, 2GB RAM
Keyboard: ES_es
I tested several MSX types. I hope it helps

By Manuel

Ascended (15839)

Manuel's picture

03-06-2016, 21:11

Please use the same workaround too☺

We cannot solve this soon (it is a problem in SDL library....)...

By Jorge Blasio

Supporter (1)

Jorge Blasio's picture

20-06-2016, 01:10

I have a similar problem.
For example, in Basic, typing

files"F:"

Produces:

dfilesd"DF;:"

Requires backtracking and deleting extra characters.

By Manuel

Ascended (15839)

Manuel's picture

20-06-2016, 07:21

What is your OS and selected keyboard layout?