Nextor - openMSX

Page 1/4
| 2 | 3 | 4

By Marcelo_Zoffy

Supporter (15)

Marcelo_Zoffy's picture

26-03-2014, 20:41

Hi,
I'm trying setting up openMSX to run Nextor without luck. I did the same configuration on BlueMSX and it works. Any tip will be very appreciated.

    <primary slot="0">

      <secondary slot="0">
        <ROM id="MSX BIOS with BASIC ROM">
          <rom>
            <filename>roms/fs-a1wsx_basic-bios2p.rom</filename>
            <sha1>f4433752d3bf876bfefb363c749d4d2e08a218b6</sha1> <!-- confirmed on Luc's machine -->
          </rom>
          <mem base="0x0000" size="0x8000"/>
        </ROM>
      </secondary>

      <secondary slot="1">
        <SunriseIDE id="Sunrise IDE">
          <mem base="0x0000" size="0x10000"/>
          <rom>
            <filename>roms/Nextor-2.0.SunriseIDE.rom</filename>
            <sha1>ab1d6dc0cb851c0ca15b260674ad884d0b8d85fb</sha1>
          </rom>
          <master>
            <type>IDEHD</type>
            <filename>hd.dsk</filename>
            <size>100</size>
          </master>
        </SunriseIDE>
      </secondary>

      <secondary slot="2">
        <MSX-MUSIC id="MSX Music">
          <rom>
            <filename>roms/fs-a1wsx_fmbasic.rom</filename>
            <sha1>aad42ba4289b33d8eed225d42cea930b7fc5c228</sha1>
            <sha1>6354ccc5c100b1c558c9395fa8c00784d2e9b0a3</sha1> <!-- on Luc's machine the last 16 bytes are 0xFC and not 0xFF -->
          </rom>
          <sound>
            <volume>9000</volume>
          </sound>
          <io base="0x7C" num="2" type="O"/>
          <mem base="0x4000" size="0x4000"/>
        </MSX-MUSIC>
      </secondary>

      <secondary slot="3"/>

    </primary>

Thank you!

Login or register to post comments

By mars2000you

Enlighted (5256)

mars2000you's picture

26-03-2014, 20:49

Remove the < 's, otherwise MRC does not display correctly the code ...

EDIT : well, you've found another solution ! Cool

By Marcelo_Zoffy

Supporter (15)

Marcelo_Zoffy's picture

26-03-2014, 20:51

Thank you mars2000you! LOL!

By Manuel

Ascended (14242)

Manuel's picture

26-03-2014, 21:23

How did you do it, Marcelo?

By the way, what doesn't work?

Also, perhaps it's easier to copy the ide extension and modify that one and use that one.

By Marcelo_Zoffy

Supporter (15)

Marcelo_Zoffy's picture

26-03-2014, 21:41

Hi Manuel, thank you for your answer.
I edited "Panasonic_FS-A1WSX.xml", and added the code:

      <secondary slot="1">
        <SunriseIDE id="Sunrise IDE">
          <mem base="0x0000" size="0x10000"/>
          <rom>
            <filename>roms/Nextor-2.0.SunriseIDE.rom</filename>
            <sha1>ab1d6dc0cb851c0ca15b260674ad884d0b8d85fb</sha1>
          </rom>
          <master>
            <type>IDEHD</type>
            <filename>hd.dsk</filename>
            <size>100</size>
          </master>
        </SunriseIDE>
      </secondary>

When I ran the machine, I did not received any error message, but MSX don't show the Nextor first screen(after MSX boot logo).
After boot, if I go to basic and type "call fdisk" I only get message "Ok", and can't access Nextor fdisk, but again, no error messages.

By Marcelo_Zoffy

Supporter (15)

Marcelo_Zoffy's picture

26-03-2014, 22:18

Sorry for the double post.
I did a copy of IDE extension and modified the code as you suggested.
Unfortunately the same problem Sad
The code of modified IDE

<?xml version="1.0" ?>
<!DOCTYPE msxconfig SYSTEM 'msxconfig2.dtd'>
<msxconfig>
  <info>
    <name>Sunrise ATA-IDE Nextor</name>
    <manufacturer>Sunrise</manufacturer>
    <code/>
    <release_year>1995</release_year>
    <description>ATA-IDE interface with hard disk.</description>
    <type>external hard disk</type>
  </info>
  <devices>
    <primary slot="any">
      <secondary slot="any">
        <SunriseIDE id="Sunrise IDE">
          <mem base="0x0000" size="0x10000"/>
          <rom>
            <filename>roms/Nextor-2.0.SunriseIDE.rom</filename>
            <sha1>ab1d6dc0cb851c0ca15b260674ad884d0b8d85fb</sha1>
          </rom>
          <master>
            <type>IDEHD</type>
            <filename>hd.dsk</filename>
            <size>100</size>
          </master>
          <slave>
            <type>IDECDROM</type>
          </slave>
        </SunriseIDE>
      </secondary>
    </primary>
  </devices>
</msxconfig>

I don't know if it's relevant or not, but the code that works on BlueMSX:

[CMOS]
Enable CMOS=1
Battery Backed=1
[FDC]
Count=1
[CPU]
Z80 Frequency=3579545Hz
[Board]
type=MSX-T9769B
[Video]
version=V9958
vram size=128kB
[Subslotted Slots]
slot 0=1
slot 1=0
slot 2=0
slot 3=1
[External Slots]
slot A=1 0
slot B=2 0
[Slots]
0 0 0 0 84 "" ""
0 0 0 0 32 "" ""
0 0 0 0 34 "" ""
0 0 0 0 26 "" ""
0 0 0 0 24 "Machines\MSX2+ - Panasonic FS-A1WSX\a1wskfn.rom" ""
0 0 0 4 20 "Machines\MSX2+ - Panasonic FS-A1WSX\a1wsbios.rom" ""
0 1 0 8 96 "Machines\MSX2+ - Panasonic FS-A1WSX\Nextor-2.0.SunriseIDE.rom" ""
0 2 2 2 78 "Machines\MSX2+ - Panasonic FS-A1WSX\a1wsmus.rom" ""
3 0 0 8 22 "" ""
3 1 0 2 20 "Machines\MSX2+ - Panasonic FS-A1WSX\a1wsext.rom" ""
3 1 2 4 42 "Machines\MSX2+ - Panasonic FS-A1WSX\a1wskdr.rom" ""
3 2 2 4 57 "Machines\MSX2+ - Panasonic FS-A1WSX\a1wsdisk.rom" ""
3 3 0 6 142 "Machines\MSX2+ - Panasonic FS-A1WSX\a1wsfirm.rom" ""

Thank you.
PS: please, sorry my very bad English.

By mars2000you

Enlighted (5256)

mars2000you's picture

26-03-2014, 22:51

Do you have tried to put the Nextor IDE rom in slot 1 or slot 2 for openMSX ?

By Marcelo_Zoffy

Supporter (15)

Marcelo_Zoffy's picture

26-03-2014, 23:12

Yes, I have tried. But I received the error message:
"Disk driver not found.
System halted."

Thank you.

By Manuel

Ascended (14242)

Manuel's picture

27-03-2014, 09:04

We'll have to investigate this issue. Thanks for reporting it!

How did you manage to paste XML in MRC? Usually it disappears...

Testing:

 
  
    Sunrise ATA-IDE Nextor
    Sunrise
    <code />
    1995
    ATA-IDE interface with hard disk.
    external hard disk
  

See? It disappears...

By mars2000you

Enlighted (5256)

mars2000you's picture

27-03-2014, 09:19

You can see the trick by clicking on QUOTE

By Marcelo_Zoffy

Supporter (15)

Marcelo_Zoffy's picture

27-03-2014, 16:16

Hi Manuel,
Thank you!!
To paste XML on MRC, I replaced < and > by html entities &lt; and &gt;

Page 1/4
| 2 | 3 | 4
My MSX profile