openMSX does not start.

Page 2/2
1 |

By Manuel

Ascended (16037)

Manuel's picture

26-01-2020, 15:19

It's a pity you removed Linux, it's a little easier to debug there.

Can you try whether a recent development build works better?

By ren

Paragon (1340)

ren's picture

26-01-2020, 20:30

Questions/suggestions:

  • have you used the installer, or are you running from the extracted zip;
  • does it launch using Catapult;
  • Catapult 'reset': delete or rename HKCU\Software\openMSX team\Catapult\
  • openMSX 'reset': delete or rename openMSX folder in 'My Documents';
  • issue set in cmd prompt: any sdl_videodriver var there? (see https://wiki.libsdl.org/FAQUsingSDL) *
  • perhaps some luck if you manually put sdl.dll in the openmsx.exe dir? (not sure if openMSX will (try to) use that instead of statically linked SDL);
  • does running openmsx.exe create the openMSX folder in My Documents?
  • try running openmsx -command "set renderer SDL"

* The SDL2 dev build won't accept directx or windib btw (you should get an error message / warning).

By assembler

Champion (391)

assembler's picture

26-01-2020, 22:01

Argfhshsssh.

New fresh installation with lubuntu.

Now openMSX works fine, although Wi-Fi doesn't work for me now, but that's another problem. XD

Before your message, ren, I tried to copy sdl.dll and sdl2.dll in openmsx directory in W7 with no luck.

Thanks for your help boys

By Manuel

Ascended (16037)

Manuel's picture

26-01-2020, 22:49

openMSX won't look for that DLL anyway. But other ideas from ren are well worth trying.

Which openMSX version do you have in that lubuntu?

By DrWh0

Paladin (772)

DrWh0's picture

28-01-2020, 13:45

I had similar problems in the past and I fixed it doing the following:

Deleting openmsx settings folder:

Under Windows (and delete registry keys mentioned by Ren):

%userprofile%\Documents\openmsx (delete whole folder)

Under linux:
~/.openmsx (delete whole folder)

Also I recommend an "apt purge openmsx*" after doing it and "apt install" afterwards DO NOT "apt reinstall" if not works repeat the process also under root user (some distros requires it)

Hope it helps

Edit:

I already see you have solved but i leave this post as recommendation for the future

Page 2/2
1 |