Openmsx no work more after Windows 10 21H1 upgrade.

Page 3/4
1 | 2 | | 4

By mandoju

Rookie (23)

mandoju's picture

31-05-2021, 13:17

Manuel wrote:

Press F10 and type: set renderer SDLGL-PP

I made this command, no have any messages, only a white screen and shut off oO
In full screen only shut off.

By Manuel

Ascended (17868)

Manuel's picture

31-05-2021, 15:59

Okay, so clearly something is wrong with your OpenGL support. Can you update the graphics driver?

By mandoju

Rookie (23)

mandoju's picture

31-05-2021, 16:14

Manuel wrote:

Okay, so clearly something is wrong with your OpenGL support. Can you update the graphics driver?

No, this is the last version Eek! .

By Manuel

Ascended (17868)

Manuel's picture

31-05-2021, 19:45

Well, looks like something got broken in them. Nothing we can do something about, I'm afraid.

By sdsnatcher73

Paragon (1846)

sdsnatcher73's picture

01-06-2021, 04:12

What is the model of your lapto and what video card does your laptop have?

By mandoju

Rookie (23)

mandoju's picture

01-06-2021, 19:22

sdsnatcher73 wrote:

What is the model of your lapto and what video card does your laptop have?

DELL VOSTRO 1014 Intel® Core™2 Duo, Intel® Media Accelerator 4500MHD Integrated Graphique Card.

By Samor

Prophet (2076)

Samor's picture

03-06-2021, 16:56

It's not Windows 10 21H1 itself anyway, OpenMSX runs fine on that, so you could try changing the graphics driver to either the one DELL recommends or the latest one from Intel itself, mileage may vary.

By Manuel

Ascended (17868)

Manuel's picture

03-06-2021, 21:22

Thanks for confirming that, Samor.

By Ivan

Ascended (9288)

Ivan's picture

03-06-2021, 21:36

openMSX 17.0 runs fine on my PC with Windows 10 21H1. And I did not uninstall v16 before installing it.

By mandoju

Rookie (23)

mandoju's picture

03-06-2021, 22:11

Ivan wrote:

openMSX 17.0 runs fine on my PC with Windows 10 21H1. And I did not uninstall v16 before installing it.

Openmsx 17.0 works fine in my Dell´s, two Optiplex 780 e one Optiplex 755 all with Nvdia Gforce GT330 and Windows 10 21H1 64bits. My Vostro Laptop only with Windows 20H2 worked fine, after upgrade for 21H1 no worked more.

This soluction works fine with Dell Vostro and Windows 10 21H1.

Can you try to edit your settings.xml file in your user folder (in "Documents/openMSX/share" I believe) and add in the settings section:

SDL

Page 3/4
1 | 2 | | 4