Please help testing upcoming openMSX release!

Page 11/11
4 | 5 | 6 | 7 | 8 | 9 | 10 |

By Grauw

Ascended (8439)

Grauw's picture

04-12-2018, 22:56

Manuel wrote:
Manel46 wrote:

I am testing the cursors in the bitmap modes of the V9990.
The colors and the EOR with the image color does not work in the emulator. it comes out black or dark blue. If it works on the real hardware.

The EOR bit isn't implemented yet, probably because there was no MSX software yet that used it Smile

Manel46: File an issue on Github and attach a test case! Big smile

By Manel46

Champion (431)

Manel46's picture

05-12-2018, 00:35

I'm trying to make a test rom. Then I would link to my Google Drive here, with the sources

By Manel46

Champion (431)

Manel46's picture

05-12-2018, 14:18

Grauw wrote:

Manel46: File an issue on Github and attach a test case! Big smile

Sorry. I do not know how GitHup works.
I know that the OpenMSX team are implementing this.
I put a link in Google Drive, with the sources. Use sjasm. EOR bits activated.
See the effect in real hardware
https://drive.google.com/open?id=1orzsBXcNpkMKKWKrIeP8QBp18a...
It is in B1 8bits / pixel. The two cursors are moved with the msx cursors

By Grauw

Ascended (8439)

Grauw's picture

05-12-2018, 14:45

It may also be good to include a photo of how it looks on the real V9990.

By Manel46

Champion (431)

Manel46's picture

05-12-2018, 15:27

By Manuel

Ascended (15740)

Manuel's picture

05-12-2018, 23:04

Thanks! It appears it is not easy to implement, so it will surely be after the 0.15.0 release.

By Manel46

Champion (431)

Manel46's picture

06-12-2018, 00:34

Thanks to all the team for this great emulator.

By Manuel

Ascended (15740)

Manuel's picture

06-12-2018, 11:22

Thanks, it is our pleasure!

By Manuel

Ascended (15740)

Manuel's picture

25-02-2019, 23:54

sd_snatcher wrote:
Quote:

sd_snatcher: thanks for reporting. It reminds me of issues like this: https://github.com/openMSX/openMSX/issues/1028

It seems to be the same problem, but manifesting different symptoms on different video drivers.

BTW, this glitch seems to happen on scale_factor 4 too.

Well, I found a workaround that avoids the glitch. If, before going fullscreen, the scale_factor is set to 2, then set back to 3 (or 4) only after the fullscreen is set, the glitch doesn't happen.

Maybe this workaround could be implemented on openMSX until the move to SDL-2 finally happens?

Does the problem still happen for you with the current development build, which is on SDL2?

By Manel46

Champion (431)

Manel46's picture

08-09-2019, 12:50

Have you tried "splitscreen" on V9990?
I don't know if OpenMSX emulates it well. The result is very different than in real HW.

Page 11/11
4 | 5 | 6 | 7 | 8 | 9 | 10 |