Please help testing upcoming openMSX release!

Page 3/8
1 | 2 | | 4 | 5 | 6 | 7 | 8

By Manuel

Ascended (14680)

Manuel's picture

04-10-2018, 21:18

DrWh0 wrote:

I have a graphic glitch in Ashguine 3

A green block appears on screen , the gameplay works ok apparently

Please try with the latest build. Wouter has fixed the issue.

For details, see https://github.com/openMSX/openMSX/commit/5eeafd749571f052cc...

The bug has been in our code since the start (this particular code: in 2002) and was reported in 2005... so it's one of the oldest bugs that were ever fixed in openMSX, I guess...

By Sylvester

Champion (378)

Sylvester's picture

04-10-2018, 22:44

Cool, just tested it and looks perfect on macOS Mojave!

Didn't understand the complete commit message, but i guess this games does something special? because i haven't seen this before with any other game.

By Grauw

Enlighted (7410)

Grauw's picture

04-10-2018, 22:57

So was it an Ashguine 3 bug as well, relying on certain VRAM initialisation, or did the bytes they do write cause the correct (invisible sprites) behaviour regardless of VRAM content?

Anyway nice catch!

By sd_snatcher

Prophet (2838)

sd_snatcher's picture

04-10-2018, 23:22

Here goes a bug report:

Bug: screen border glitches and constantly flashes in red.
Tested on: openmsx-0.14.0-366-g5eeafd749-mac-x86_64-bin.dmg on Mac OS 10.13.6
Steps to reproduce:

1) Start openMSX in windowed mode
2) open the console and type:

set scale_factor 3

3) Close the console
4) Type CMD+F to go fullscreen

The screen border will flash like crazy in red/black/red. (around 20Hz, I believe)

I'm using the scale_algorithm "simple" and the renderer "SDLGL-PP". If I change to the rendered "SDL", this problem doesn't seem to happen, but then some garbage left on the outer border if I open/close the console on fullscreen.

By Manuel

Ascended (14680)

Manuel's picture

04-10-2018, 23:24

Sylvester and Grauw, here's what our experts say:
< Quibus> I'm actually quite surprised that Ashguine 3 is the only game that suffered from this bug. I can't remember a single other issue that could be solved by this fix.
< wouterv> Quibus: it requires setting up sprite attributes that normally result in non visible sprites. I don't think it's something that a game would do intentionally
< mth> I'd actually call what Ashguine 3 does a bug
< mth> but it happens to be a harmless bug
< wouterv> it is. It uses uninitialized VRAM

By Manuel

Ascended (14680)

Manuel's picture

04-10-2018, 23:28

sd_snatcher: thanks for reporting. It reminds me of issues like this: https://github.com/openMSX/openMSX/issues/1028 That is, we have several issues with full screen, but they're all inside the SDL 1.2 library we use (openMSX has no special code for full screen, it just toggles some flag in SDL, basically).

There's nothing we can do about it, but once we've moved to SDL2, I expect that these issues will be gone.

By sd_snatcher

Prophet (2838)

sd_snatcher's picture

04-10-2018, 23:39

Quote:

sd_snatcher: thanks for reporting. It reminds me of issues like this: https://github.com/openMSX/openMSX/issues/1028

It seems to be the same problem, but manifesting different symptoms on different video drivers.

BTW, this glitch seems to happen on scale_factor 4 too.

Well, I found a workaround that avoids the glitch. If, before going fullscreen, the scale_factor is set to 2, then set back to 3 (or 4) only after the fullscreen is set, the glitch doesn't happen.

Maybe this workaround could be implemented on openMSX until the move to SDL-2 finally happens?

By DrWh0

Paladin (712)

DrWh0's picture

05-10-2018, 00:46

Finally, Ashguine 3 bug solved! Smile

By sd_snatcher

Prophet (2838)

sd_snatcher's picture

06-10-2018, 16:31

I just tested, and the function-keys problem on Mac OS-X still happens on the latest build.

Steps to reproduce:

1) open the console and type

bind F9 toggle throttle

2) The F9 key will work fine if the console is closed. But when the console is open, only a square will be print on the console and the speed throttle won't be changed.

It also happens with other function keys, for example if you try:

bind F11 toggle mute

By Manuel

Ascended (14680)

Manuel's picture

06-10-2018, 21:49

sd_snatcher: indeed, it still happens, because no one worked on that issue. The problem seems to be macOS specific, as the ticket comments say.

Page 3/8
1 | 2 | | 4 | 5 | 6 | 7 | 8
My MSX profile