Please help testing upcoming openMSX release!

Page 44/61
37 | 38 | 39 | 40 | 41 | 42 | 43 | | 45 | 46 | 47 | 48 | 49

By Manuel

Ascended (18162)

Manuel's picture

21-07-2020, 22:51

Grauw wrote:

When I record, fast-forward does not work. Is that intentional?

This should be fixed now, can you confirm?

By mzoran

Master (135)

mzoran's picture

21-07-2020, 23:20

I have unzipped the latest Windows build .886 and Catapult won't start. It just says Unable to load resources !
.851 was working fine. Not sure if unzipping directly over the previous install made some mess.

By Manuel

Ascended (18162)

Manuel's picture

22-07-2020, 00:20

Yeah, something is wrong with it, NYYRIKKI also reported that. I am trying to reach Vampier about it.

Does it work if you use the MSI installer?

By mzoran

Master (135)

mzoran's picture

22-07-2020, 22:08

Unfortunately it is the same situation with the MSI installer.

By wouter_

Champion (467)

wouter_'s picture

23-07-2020, 17:51

S0urceror wrote:

@wouter, thx for the tips. So it looks like I can run any Tcl but if I’m connected as a debugger through the socket how can I see the stderr output of such a script? Or the cputrace output?

Is there a way to trigger an just like when a breakpoint is hit.

@S0urceror: Sorry, I overlooked your question.

Short answer: at the moment this is not (yet) possible.

Longer answer: maybe you can use the message command? Full syntax is:
message <string> <level>
This will send a log event over the socket connection. More specifically it will send something like:
<log level="info">bla</log>
Currently level must be one of info, warning, error or progress. Though this command was originally only intended to show messages to the user, so currently those messages also show up on the openMSX screen. Maybe we could add a new level like debug that (by default) does not show up? (Not a solution, but for now you can experiment with changing the message_callback setting, this callback transforms the log event into an on-screen message box. Execute about message_callback for a bit more information).

@S0urceror: What do you think? Feel free to make other suggestions.

By Grauw

Ascended (10070)

Grauw's picture

23-07-2020, 19:11

Manuel wrote:
Grauw wrote:

When I record, fast-forward does not work. Is that intentional?

This should be fixed now, can you confirm?

Sorry, I missed your message earlier. I just checked and played around with changing to various speeds before and during recording, and the resulting video seems to be correctly generated while the emulator’s speed changes as expected.

By Manuel

Ascended (18162)

Manuel's picture

24-07-2020, 22:21

@Grauw: Thanks!

@mzoran: please try the latest build. Vampier told me he fixed things.

By mzoran

Master (135)

mzoran's picture

25-07-2020, 04:22

Yup, seems fixed. I unzipped it over the 851 version and it worked. Thanks

By RibbSayan

Expert (69)

RibbSayan's picture

25-07-2020, 09:30

Hello,
I've an issue with openMSX. When i'm playing aleste, the scrolling isn't smooth. I'm under windows X with catapult launcher (all last versions released, tested with SDL and SDLGL-PP Renderer)
If you want any further informations.
Thanks

By Manuel

Ascended (18162)

Manuel's picture

25-07-2020, 10:00

Are you running a development version on a modern PC?
If yes, use SDLGL-PP with vsync enabled for the best experience.

Page 44/61
37 | 38 | 39 | 40 | 41 | 42 | 43 | | 45 | 46 | 47 | 48 | 49