Please help testing upcoming openMSX release!

Page 8/11
1 | 2 | 3 | 4 | 5 | 6 | 7 | | 9 | 10 | 11

By mth

Champion (484)

mth's picture

16-10-2018, 12:14

I don't know the exact function used: it's possible that it reaches a ceiling, but it is also possible it will keep growing slowly. In any case, it won't grow nearly as fast as in the first minute.

By wouter_

Champion (418)

wouter_'s picture

16-10-2018, 17:45

mth wrote:

I don't know the exact function used: it's possible that it reaches a ceiling, but it is also possible it will keep growing slowly. In any case, it won't grow nearly as fast as in the first minute.

Memory usage of the openMSX reverse system grows logarithmic wrt time. Thus in theory there's no ceiling, but in practice, after a little while, it grows extremely slow.
Also when the content of a memory block (e.g. the MoonSound sample ram) doesn't change between snapshots, it'll hardly take up any space for the reverse system.

By Manuel

Ascended (15762)

Manuel's picture

18-10-2018, 00:21

Manuel wrote:

So, please tell me the details on the errors you got. I'd like to debug this issue.

Any news here DrWh0? Can you give us the details on these errors?

By DrWh0

Paladin (767)

DrWh0's picture

19-10-2018, 00:59

Manuel wrote:
Manuel wrote:

So, please tell me the details on the errors you got. I'd like to debug this issue.

Any news here DrWh0? Can you give us the details on these errors?

Sorry for the delay (I am having a lot of work on various fronts)

I will try to record a video or make some debugging code to show you the error as soon as I can.

By DrWh0

Paladin (767)

DrWh0's picture

19-10-2018, 16:01

The bug is solved on latest builds, all tcl files are processes correctly now, thank you very much for fixing this Smile

By Manuel

Ascended (15762)

Manuel's picture

19-10-2018, 16:43

We did not fix anything for this issue... So, are you sure??

By DrWh0

Paladin (767)

DrWh0's picture

19-10-2018, 17:15

Yep, absolutely, Manuel

I created an empty file with notepad and every single line is processed properly now even the copy/pasted ones, even I have modified the previously saved tcl and still works.

I have tested various builds and the bug has been corrected 100% (I have tested the latest 4 Windows builds and the bug seems to be fixed).

Also I backed to 0.14 stable and the bug reappeared Smile

Maybe a non documented typo somewhere?

The user who reported the issue initially should confirm if the last builds works for him too so we can finally close that issue or not.

By Manuel

Ascended (15762)

Manuel's picture

19-10-2018, 22:35

Can you find out which build fixes it for you?

By Manuel

Ascended (15762)

Manuel's picture

21-10-2018, 00:15

wouter_ wrote:
sd_snatcher wrote:

Suggestion: whenever a debug break occurs, it should signal the frame skipper that the next frame has to be forcibly drawn.

I implemented this (or something close to it). Could you please verify with the latest development snapshot?

sd_snatcher: can you confirm, please?

By Tolvatar

Paladin (949)

Tolvatar's picture

24-10-2018, 20:25

May i ask if tsx casete images can be loaded with the new build?
Sorry for my bad english

Page 8/11
1 | 2 | 3 | 4 | 5 | 6 | 7 | | 9 | 10 | 11