Symbos + Openmsx mouse

Page 2/3
1 | | 3

By Manuel

Ascended (13469)

Manuel's picture

10-01-2014, 21:17

Did you give that plug command before loading SYmbOS? That was the question Smile

By slowerisbetter

Master (191)

slowerisbetter's picture

11-01-2014, 11:07

Jikes, I must be blind and even though I use a real MSX almost daily I didn't expect I had to plug it in 'first' so I read over that. *Embarrassed*. Thanks guys!

By Manuel

Ascended (13469)

Manuel's picture

11-01-2014, 11:10

There's not much MSX software that supports hotplugging mice... in fact, most manuals say that you can only plug stuff in the joystick connector when the machine is off Tongue

By edoz

Paragon (1968)

edoz's picture

11-01-2014, 11:33

I think it is possible to hot- plug a mouse in Symbos but I forgot the key combination..
Graph-1 or code-1 or select-1 .. something like that .. to reinitialize the port again in Symbos. (without MSX or symbos restart.)

By edoz

Paragon (1968)

edoz's picture

11-01-2014, 11:47

Just found out again how you can do this in symbos

-You can move the mouse pointer with GRAPH + Arrow keys (if you don't have a mouse)
-You can re-initialize the mouse again (scan mouse) with key combination GRAPH+SELECT

Maybe this helps a bit

By slowerisbetter

Master (191)

slowerisbetter's picture

11-01-2014, 11:44

Manuel wrote:

There's not much MSX software that supports hotplugging mice... in fact, most manuals say that you can only plug stuff in the joystick connector when the machine is off Tongue

Yeah, but on my real hardware the mouse + joystick are always plugged in so that's why I never noticed or thought about it.

By slowerisbetter

Master (191)

slowerisbetter's picture

11-01-2014, 11:45

Thanks Edoz; the re-scan scounds good! I think that's a wonderful feature to have in this day and age Smile

By Prodatron

Paragon (1786)

Prodatron's picture

11-01-2014, 15:00

Yes, indeed GRAPH+SELECT does a Joystick-port re-scan. IIRC it was introduced to make it possible to switch mouse/joystick between the two ports or to test different mouses.

By DamnedAngel

Resident (48)

DamnedAngel's picture

06-09-2017, 01:17

Hi all

sorry for resurrecting such a dead topic, but I am stuck with same problem, with SymbOS 3.

Environment:
- openMSX 0.14.0
- Machine Panasonic FS-A1GT
- IDE
- gfx9000
- Misc Controls | Connectors | Joystick port 1: mouse
- MSX-DOS 2.20
- SymbOS 3

Tried:
- plug joyporta mouse
- set grabinput on
- GRAPH+SELECT to re-scan Joystick-port

All these BEFORE executing SymbOS

Result:
- No mouse control
- No cursor on the screen

I feel I am probably doing something very stupid, or very stupidly NOT doing something. But I can't figure out what exactly.

Any thoughts?

TIA,
DA

By DamnedAngel

Resident (48)

DamnedAngel's picture

06-09-2017, 03:19

Hi all again,

I THINK that what is happening is that Symbos is crashing/hanging, and not that the mouse is not being properly acessed. Maybe a problem in devide configuration.

I will keep trying and let you posted. If, in the meantime, anybody has any tips or ideas, please let me know!

best,
DA

Page 2/3
1 | | 3
My MSX profile