Aleste 2 ROM

Page 5/18
1 | 2 | 3 | 4 | | 6 | 7 | 8 | 9 | 10

By ericb59

Paladin (875)

ericb59's picture

09-03-2015, 07:02

please do also an Ascii16K mapper version Eek!

By Guillian

Prophet (3231)

Guillian's picture

09-03-2015, 08:56

Fish wrote:

Very nice work! I have got this rom working on a Sony HBF700 with the /U option for the MegaflashromScc.
I can get until the title screen, when the first level should be loading I only get a black screen. Any suggestions?

I have tested it on MegaFlashROM SCC+ SD and seems to work only on slot 1.
I used:
OPFXSD ALESTE2.ROM /K5 /U

By Fish

Rookie (22)

Fish's picture

09-03-2015, 22:51

Tried it again, didn't work with the /K5 /U options. Also, if you emulate a HBF700P I have encountered the same problems.

By Randam

Paladin (916)

Randam's picture

10-03-2015, 21:45

Translations plural? Are you also intending to make an improved shalom version or something like that?

By ricbit

Champion (438)

ricbit's picture

11-03-2015, 18:46

Good news, my slot expander has just arrived! Now I can resume work on this project Smile

@Randam Not really, but an Aleste 2 retranslation from scratch is in the works.

By Louthrax

Prophet (2093)

Louthrax's picture

13-03-2015, 16:57

I noticed something while testing Aleste 2 disk version using RunIt on various MSX configurations : if you have an external RAM expansion (which is the case with some MegaFlashROM SCC+ SD), a RAM detection routine in the game does not work and causes a crash.

I've been able to fix that by taking the RAM slots provided by the disk-interface instead of calling this routine. Patch is the following:

3e 00 cd e5 d3 -> 3a 41 f3 00 00
3e 40 cd e5 d3 -> 3a 42 43 00 00
3e 00 cd e6 d3 -> 3a 41 f3 00 00
3e 40 cd e6 d3 -> 3a 42 43 00 00
3e 80 cd ee d0 -> 3a 43 f3 00 00
3e c0 cd ee d0 -> 3a 44 f3 00 00

Ricbit, you maybe don't want to use the F341-F344 values, as they exist only if a disk-interface is present, but it might give you a hint on how to fix the faulty routine (d3e5/d3e6 and d0ee...).

By ricbit

Champion (438)

ricbit's picture

13-03-2015, 17:07

Thanks for the hint, I'll have some time on the weekend to fix this.

By Vampier

Prophet (2297)

Vampier's picture

13-03-2015, 18:30

ricbit that would explain why it didn't run on cbios (no disk roms)

By Louthrax

Prophet (2093)

Louthrax's picture

13-03-2015, 18:49

No, the diskrom is needed only with my patch. The original Aleste 2 routine does something wrong when detecting the RAM, and it does not use the BIOS (just some accesses to FCC1-FCC4h).

By ricbit

Champion (438)

ricbit's picture

16-03-2015, 16:11

Meh, the slot expander didn't make a difference, the acvs megaram with 2mb just doesn't work with the turboR GT. What is the best solution currently available to add 2mb to my GT? I'm game for anything, it can either be a 2mb external mapper or a 2mb flash cart.

Page 5/18
1 | 2 | 3 | 4 | | 6 | 7 | 8 | 9 | 10