Are people here using the Radio App in SymbOS?

Page 2/2
1 |

By edoz

Prophet (2086)

edoz's picture

27-08-2018, 12:22

enribar wrote:

Ok, I'm convinced that this app needs a restyle, for example, a design that looks like autoradios and colours with gray, black and blue, ok like the default winamp's skin (my taste). Anyway great app! I'm very interested in its development.

I agree on the looks of WinAmp, but SymbOS is using a fixed 16 color pallet. Unfortunately, there is only 1 gray here. However I think the colors of the pallette in SymbOS are very good if you take the compatibility in mind. The first 4 colors are used on systems/modes that only supports 4 colors. In a way you could make a very nice application if you could choose your own 16 colors, but it is just that symbOS has to care about other applications and modes which makes the pallette fixed.

This are the colors i can choose..

The same issue i have a on the email application i'm working on...
i have only one gray.. how ever, i replaced one gray with a darker gray.. but.. this was done in Quigs and would not be possible in SymbOS.. We already discussed to replace one color for dark gray.. but not sure this is a good thing to do.

The funny thing is that with one gray you still can make gray images ;)

By hamlet

Scribe (1789)

hamlet's picture

27-08-2018, 17:47

Quote:

The funny thing is that with one gray you still can make gray images Wink

Two shades of gray:
Back in the days, when Seymour Cray heard that Apple Inc. would use a Cray-1 to develop a successor to the Apple II, he said. "Funny, I just bought an Apple II to develop my Cray-2."
Great work edoz and a nice new avatar!

By gflorez

Supporter (13)

gflorez's picture

19-10-2018, 20:30

Please, Edoz. I am gflorez, from Spain.

Your Radio app works also on the SymbOS port for Enterprise(this deserves a longer explanation, as I have made a MSX cartridge adaptor for Enterprise computers), but with wrong colours as it has been made for 16 colours. Can you fix it?

Thanks.

By edoz

Prophet (2086)

edoz's picture

22-10-2018, 18:21

Shocked! Shocked! Shocked! Shocked! Shocked! I'm shocked Big smile Big smile So the app is working on the Enterprise while i never tested that?? And it works??
Screenshot please Big smile Big smile

As this application was a "hardware" application i never took care about the 4 color pallette. But it seem i have to do this now Big smile Of course i can fix it for you! I'm glad to do it!

By hamlet

Scribe (1789)

hamlet's picture

22-10-2018, 18:57

Nice! gflorez you did a MSX cartridge adaptor? I wanna know more! Please send pics!
edoz, amazing, SymbOS is much more than we imagine. Will you bring a Enterprise to the fair? It must been decades since I saw one...

By gflorez

Supporter (13)

gflorez's picture

22-10-2018, 20:54

This is the adaptor inserted on a slot of an Enterprise bus expander.

Of course, it works! Thanks to Prodatron's mastery, your app code asumes that the ports of the SE-one are on 20h-2Fh, the same as on the Enterprise, because the adapter only changes the positión of the signal pins. The Z80 bus is the same on both MSX and Enterprise, and these ports where not used by any hardware in the past.

You can talk with Hans of TMTlogic, his web page holds this video on some place:

https://www.youtube.com/watch?v=muLnypBey6M

Here you can see the first prototype, running on a 10Mhz Enterprise with the Basic programs and with SymAmp on SymbOS, directly, without modifications.

By edoz

Prophet (2086)

edoz's picture

23-10-2018, 16:14

Wow! Thank you for the update. I see what you mean. The bit- alignment is corrupt on the Enterprise in my application. I try to fix that. Big smile It's very nice to see those hardware exchanges currently between SymbOS systems.

By gflorez

Supporter (13)

gflorez's picture

23-10-2018, 18:32

Yes, it is amazing to see the same cartridge working on three different systems...The next step is to try the GFX-NINE...

Page 2/2
1 |
My MSX profile