Pointless Fighiting "Cammy bug" on real machine

Page 1/3
| 2 | 3

By DaikuMaryuGaiking

Resident (53)

DaikuMaryuGaiking's picture

08-01-2015, 02:22

Hi!
I was so happy for publish of Pointless Fighting that I load the ROM on my NMS8280 with Mega Flash Rom model SCC+ 512k SD 8MbyteFlash Rom and FM Pac.
MFR in slot 1 and FM Pac Slot 2.
The game was ok, but when come select Cammy like fighter the game go in graphic crash!

The "versus" screen show a black square where there is Cammy, and during game Cammy is invisible with slow motion and trace graphic of enemy movement.

...also with mega flash rom, you have to load the game with the "/ U" otherwise no charge.
Using the "/ U" you can not use "/ H60" to activate your 60 hz.

Any solution?

Login or register to post comments

By Daemos

Paragon (1649)

Daemos's picture

08-01-2015, 08:14

problematic slotswitching. the 512Kb RAM is on the same slot as the romdata and that ram gets found first. The game is unable to fetch its data once that happens. The /u parameter disables the 512k ram on the megaflashrom so that should fix it. the 60 hz gets automaticly activated by the game since the game depends on the 60 hz. It propably runs on 30 fps. Try disabling the internal memory mapper of the megaflashrom if /u is not the switch to disable it.

you can also force the slot with /s 1

By DaikuMaryuGaiking

Resident (53)

DaikuMaryuGaiking's picture

08-01-2015, 20:04

Cammy bug is again there! .... -_-

By anonymous

incognito ergo sum (109)

anonymous's picture

08-01-2015, 20:13

First of all thanks to Baka-Yo! Softcorp for finished the game. Really awesome!!

I´ve been playing in Turbo R and MSX2 8245 ( Real machines, not emulator) and I would like to report that before or after, the game crash when I win the stage and I have to go to a new one. A couple of pics, one in Turbo R and other in 8245.
Playing from Megaflash SCC+ SD (not 512kb)


By Daemos

Paragon (1649)

Daemos's picture

08-01-2015, 20:17

.... Yes I remember this bug.. if I could only remember what it was. This is not caused by the slotstuff but by something else. It should only happen on real machines. Somehow emulators steer clean from this problem. The fix was so easy. If only I could remember.

By syn

Paragon (1628)

syn's picture

09-01-2015, 23:55

I read on the banzai shoutbox (http://msxbanzai.tni.nl/) that this problem is caused by hw (the mfr+sd)...

By Guillian

Prophet (3027)

Guillian's picture

10-01-2015, 10:48

In that page, GuyveR800 said that he figured out the problem and that it is on OPFXSD. But he is wrong.
The problem is that ASCII16 mapper is limited to 1MB. Anyway, you can play the game using this OPFXSD.
I have finished the game on turbo R ST without problem.
(Adding /U to fix problem of the game handling the subslots)

By raulsantacruz

Champion (467)

raulsantacruz's picture

10-01-2015, 10:59

Hi!!!,

I tested too in Turbo R ST and I can confirm the Guillian's comments. It's amazing and the R800 indicator is OFF all the time. Absolutely amazing port to MSX!!! In the 90's I would kill for this!!!

Regards!

By ericb59

Paladin (733)

ericb59's picture

10-01-2015, 11:06

@Guillian : ASCII16 Mapper with real chips (sharp LZ93A13 for example ) can address up to 2 MB

By Guillian

Prophet (3027)

Guillian's picture

10-01-2015, 11:35

@eric59:
What I wanted to mean is that the problem is that the ASC16 mapper of MegaFlashROM SCC+ is limted to 1MB as BiFi find out.
By the way, ASC1 and ASC4 (LZ93A13 and MR6401) can address up to 2MB in 16K mode. ASC2 and ASC3 (M60002 and BS6101) can address up to 4MB.

By Manuel

Ascended (13478)

Manuel's picture

10-01-2015, 15:16

Guillian: should I change something to the MFR SCC+ SD emulation? Or even also the MFR SCC+?

Page 1/3
| 2 | 3
My MSX profile