SofaRun v2.0 bug report thread

Page 26/27
19 | 20 | 21 | 22 | 23 | 24 | 25 | | 27

By Louthrax

Paragon (1823)

Louthrax's picture

16-03-2018, 20:47

Moniz wrote:

Fleet Commander 2 won't start, I tried different mappers and devices (1024 external mapper and megaflash-scc 512).
It also won't work when flashing with opf to MFRscc512

I'm using a Sony HB700p with 1024 external mapper, IDE HDD and Megaflash512scc

Great piece of work btw!! (haven't tried it till recently Cool )

Try the ASCII-8 mapper with MFRSCC, that should work. Let me know if not!

By Moniz

Champion (340)

Moniz's picture

24-03-2018, 12:30

I've tried all the mappers, including Ascii-8, I have a black screen after startup, game won't start at all

By mtini

Expert (92)

mtini's picture

27-03-2018, 04:34

'm trying to use SofaRun to run Metal Gear (already with the SRAM patch) in conjunction with Game Master 2 to save the progress of the Metal Gear game on SRAM but it's not being possible. I used the patch from the MSX IPS Patch Archive site (http://ips.tni.nl/rom/fixes-other/konami/RC750E55.IPS) with the european version of the game but when saving the game the same hangs on the game screen. I am using the SD-MAPPER / Megaram of 512kb and my equipment is an MSX TurboR A1GT.

By Wolverine_nl

Paladin (887)

Wolverine_nl's picture

27-03-2018, 11:15

Hi Louthrax,
I tried to run a concatted Xak3 with Sofarun, but it gives a black screen, the FM-PAC music does start playing.
Tried it with Runit without options, then it doesn't work, but with the /P option, it works fine, but no option to use a user-disk to save. So I want to use Sofarun like I use with all other games.
I could not find that option in Sofarun, (I did find the option to change the MSX type in the standard settings, but it doesn't work like /P works in Runit)
I am using a MSX TurboR A1GT with a MFR-SCC-512-SD.
Maybe I missed a way to run it here somewhere, but coulnd't find it.

By Wolverine_nl

Paladin (887)

Wolverine_nl's picture

27-03-2018, 20:02

Never mind, i put the settings Disk Delay to 1 and it works Wink

By ale1750

Supporter (7)

ale1750's picture

12-04-2018, 17:11

Hi Louthrax, first of all I want to thank you for the Sofa suite and for your support.
I'm quite new to roms and flash carts, I updated my Carnivore2 just 2 days ago and started making some test.
Most of the roms I tried worked flawlessly at first try, I only can't get the english versions of Metal Gear 2 and Snatcher to work.
Metal Gear 2 I tried more or less every rom I could find, it starts perfectly but as soon as Snake appears (just before the first communicator scene) it blocks.
Snatcher... I was only able to start the japanese version with SRI, but wasn't able to change to the second floppy (I tried pressing everything, 1,2,3 and a,b,c,q,w,e...), and never got to start the english version.
I'm running a Panasonic A1WX and a Carnivore2 with a 1gb cf and all the last updates.

By Louthrax

Paragon (1823)

Louthrax's picture

12-04-2018, 19:37

Hi ale & welcome here!

Metal Gear 2 should work, at least on MFR and with the standard ROM... Not completely sure anymore but I think the translated version was working too. I'll try to check that on Carnivore when I'll have time.

For Snatcher, the disk version does not work, but you can try to install it on your SD Card (I think with the version that can be found here: http://www.amusementfactory.com.br/msx/snatcher/).

By ale1750

Supporter (7)

ale1750's picture

13-04-2018, 10:17

Hi Louthrax, thank you for your help.
I tried installing it from the disks I found in the link you provided (I downloaded the images, wrote them to real disks and then run the installer). Everything completed correctly but when I try to start the game it won't work.
I go with these settings: SCC+ on slot 1.0, 60hz. The game in installed in the root, a:/snatcher

By mgoulart

Supporter (6)

mgoulart's picture

30-04-2018, 05:02

Hi Louthrax,

First of all, I'm huge fan of your job.

I'm facing a little problem with my ZIP file that contain a collection of .CAS files. All files that I try to run on Sofarun results on the same problem.

"Unable to open"

When I select a .CAS file in the .ZIP file, Sofarun creates a temporary file .UNZ (I guess!) but when it finishes the creation, the message above appears and the Sofarun quits.

I tried on 3.2 and 2.7 with the same result. Any idea what I'm doing wrong?

Thanks!

By sdsnatcher73

Master (147)

sdsnatcher73's picture

14-05-2018, 08:35

Hi Louthrax, I'm using SofaRun on an OCM. The OCM implements ESE-MegaRAM in 4 forms (ASCII-8K 1024kB, ASCII-16K 2048kB, SCC+ 1024K and SCC+2048kB). My guess is that the original implementations of these cartridges used persistent flash storage, but on the OCM they use RAM (which persists only during a soft reset on OCM). The issue is now that SR expects a game if loaded again to be still in the flash, on OCM this is not the case and thus the game does not start (as it is not loaded twice).

Could you think of a way to fix this for OCM/Zemmix users? Maybe dedicated versions of those cartridges for OCM in SR with a flag telling SR it is not persistent?

Page 26/27
19 | 20 | 21 | 22 | 23 | 24 | 25 | | 27
My MSX profile