IDE-CF , blueMSX and Symbos

By enribar

Paragon (1171)

enribar's picture

13-11-2008, 09:27

Hi to all,

I made some experiments in creating and configuring CF images with blueMSX emulating Sunrise's IDE. All well done!
Created 2 partitions: one FAT12 partition and one FAT16 partition.

I tried to run last version of Symbos, too, from the FAT12 partition. But now some problems arise...
I launched a wrong command of Symbos (A:>SYMBOS -F... etc) and now the operating system boots authomatically bypassing MSX-DOS. Also, drives are not configured (no possibilities to read or write in any drive).
And finally, I cannot restore the disk image, Symbos boots at any system reset... Crying

Anyone can help me?
Can you tell me the right Symbos boot command for such configuration? (FAT12 (boot) + FAT16 in 128MB CF disk?)

Thankyou in advance

Login or register to post comments

By enribar

Paragon (1171)

enribar's picture

14-11-2008, 15:27

I reply to myself...

1) made a 128MB HD with openMSX's "diskmanipulator" utility: 4 partitions of 32MB each;
2) copied inside DOS2 and SymbOS 2.0, in partition with drive A:;
3) tried to run SymbOS with these commands:

A:>SYMBOS -F0 M61 P1
- ...

all combinations seem to fail, because I can see SymbOS's desktop, mouse works, but each application opening action returns an error dialog windows (error 26...).

Can you help me?

By giuseve

Paladin (751)

giuseve's picture

15-03-2012, 17:32

It happens in similar way to me too.
Did you resolve it?
Can you help me?


By Manuel

Ascended (18794)

Manuel's picture

15-03-2012, 19:13

I actually also got that error 26 when trying to get SymbOS working again. I have no idea what it means, maybe it's documented somewhere?