openMSX 0.6.3: please help betatesting!

Page 1/5
| 2 | 3 | 4 | 5

By Manuel

Ascended (19314)

Manuel's picture

04-09-2007, 23:33

Hello all,

Using the help of various people, we managed to compile a Win32 beta version of our upcoming openMSX 0.6.3 release. You can help us a lot by trying it out and telling us if things work as you expect.Hello all,

Using the help of various people, we managed to compile a Win32 beta version of our upcoming openMSX 0.6.3 release. You can help us a lot by trying it out and telling us if things work as you expect. (The important changes can be found in the draft of the release notes in doc/release-notes.txt.)

We are still very interested in developers who want to help out on a structural basis!

Anyway, please install it and give feedback if things work well (especially stability, new features
and the installer).

First tests on a few systems seem to indicate it's OK, but your input is
highly interesting. Please let us know!

Also, you can (still) try out the source code as well: please try to compile and run it (on whatever OS you have) and report your findings here, in our forums ( or on IRC.

If you need help to compile it, you could start here:

Or ask us via the aforementioned methods.

Thanks in advance!

Login or register to post comments

By SLotman

Paragon (1242)

SLotman's picture

05-09-2007, 04:33

(Please bare with me, I'm quickly testing and writing this reply as I test)

Here on Win98, gfx card Geforce4MX4000, using catapult, openMSX just crashes - running Panasonic FS-A1ST... when I tried an Expert DDPlus it worked. Both machines passes the catapult check.

Portuguese (sorry) info from Windows, if any help at all
(I never understood those, but who knows...)
OPENMSX causou uma falha de página inválida no
módulo <desconhecido> em 00de:0157ef6b.
EAX=00000056 CS=023f EIP=0157ef6b EFLGS=00010206
EBX=0157f684 SS=0247 ESP=0157f65c EBP=0157f698
ECX=0157ef68 DS=0247 ESI=007d7570 FS=5a7f
EDX=474e5543 ES=0247 EDI=02562e70 GS=0000
Bytes em CS:EIP:
01 10 94 55 02 1c c2 5e 01 87 a0 55 02 00 a0 55
Esvaziamento da pilha:
007411dc 00000001 00000001 432b2b00 474e5543 02562e70 0157f684 0157f68c 0073bd80 0157f630 0157ef0c 0157f72c 02562e70 007d7570 0157f770 0157f6a8

When I tried running a dsk image with catapult, on a machine *without fdc*, it showed an error (no fdc) in the message area, and the "select machine" combo was disabled, but the emulator wasn't running at all (no crash)

Now I tried the DDPlus with a ROM image, and the emulator crashed, just like with the A1ST. Running the same machine without the ROM, it works. (Running from catapult also).

Seeing the above, I tried running A1ST with nothing else (no ROM or DSK) and it worked. So seems there is a bug or in catapult or how openMSX is using file paths.

Yes, I made it work: changed d:\emus\msx\port\montezuma\rom\montrom.rom to d:/emus/msx/port/montezuma/rom/montrom.rom and it worked!

Hmmm... but A1ST trying to run the ROM crashed again. Not even changing the path from \ to / helped. But again, running without dsk or rom, it works.

Just tested and the same happens with A1GT. A turbo-R specific problem???

Tried with the A1WSX, and before crashing, got this error:

Using specified machine: Panasonic_FS-A1WSX
Uncaught exception in subthread: -cart not found in this context

cart not found?!?!?!

Well, I'm back to programming, must finish as much as I can for MSXRio =D

By Manuel

Ascended (19314)

Manuel's picture

05-09-2007, 09:06


First of all: thanks for testing Slotman!

I wonder if these crashes only happens on Windows 98. (I can't reproduce any of these problems on Windows XP at work.)

Can you try without Catapult? E.g. try in the command prompt:

openmsx -machine Panasonic_FS-A1ST  -cart d:\emus\msx\port\montezuma\rom\montrom.rom

Here's some replies to your findings:
1) Crashing openMSX: should never happen, I have no idea why. I really wonder if this is only on non-NT Windows.
2) Using a disk image on a machine without FDC should indeed fail, but should not disable the combo. I'll try to test that and see what happens. (Tested: works fine on Windows XP at work.)
3) I don't think there is a turboR specific problem, the machine shouldn't matter.
4) For some reason, "-cart" is being used as a filename, instead of an option. Seems to be a problem in Catapult. Does this happen with all machines that cause a crash? (Not only the WSX.)

Any other people having those kinds of problems?

General note: especially for this kind of problem (which probably only happens on certain Windows versions), we need a Win32-oriented openMSX developer to pursue this. Smile
General note 2: reporting success is also useful!
General note 3: thinking "I'll wait for the release" is not helpful... it's very frustrating to get bug reports (especially ones like this) right *after* the release, while it would have been easy to test before the release and report the bugs in time.

By Manuel

Ascended (19314)

Manuel's picture

07-09-2007, 09:08

We had a couple of dozen downloads. Any results, folks?

By Philip

Champion (380)

Philip's picture

07-09-2007, 12:54

I tested the installer version on Vista, tried a few machines, some roms, some disks and everything just works !

By Jipe

Paragon (1604)

Jipe's picture

07-09-2007, 15:42

I tested on Athlon 1100 GeForce2 and XP 1st Ed

i test only C Bios , catapult with default config and Megarom -> work fine

By nikodr

Paladin (750)

nikodr's picture

07-09-2007, 16:35

Just tested it on a windows xp service pack 2 on a amd athlon 64 3200+ with a geforce 5700 and 1024 mbytes of ram i only tested it with c-bios msx2 but everything seems to be perfect.

By Manuel

Ascended (19314)

Manuel's picture

07-09-2007, 22:22

Great, thanks for testing so far folks. This makes me suspect more and more that things only go wrong on older Windows systems, like 98 and ME. Can someone confirm this?

By Alex

Master (205)

Alex's picture

08-09-2007, 00:56

Just tested it on my old PC. It's a Pentium MMX 166 MHz with 64 MB memory, running Windows 95. Don't remember anymore which videocard it has.

Anyway, both catapult and openMSX fail to start on this ancient machine.

Catapult fails with following error message: the catapult.exe file is linked to missing export SHELL32.DLL:SHGetSpecialFolderPathA.

openMSX failes with " this program has performed an illegal operation and will be shutdown" with details:
OPENMSX executed an invalid instruction in module OPENMSX.EXE at 0137:0069484f
EAX=00400000 CS=0137 EIP=0069484F
EBX=0000ffff SS=013f ESP=0157fde0
ECX=00000001 DS=013f ESI=00000001 FS=11af
... (the rest I don't know, I forgot to scroll-down when I took the screenshot)

Will try tomorrow on my "new" PC (AMD Athlon XP 1800+, 377 MB memory,
ATI Radeon RV100 QY [Radeon 7000/VE], running WinXP SP2)

By Sonic_aka_T

Enlighted (4130)

Sonic_aka_T's picture

08-09-2007, 10:18

Tested on XP SP2, no issues... (love the installer btw!)

By Manuel

Ascended (19314)

Manuel's picture

08-09-2007, 11:22

Alex: thanks for testing. The SHELL32.DLL comes with IE 4 or higher, AFAIK (this is were MS started integrating IE with the desktop).
The register dump doesn't help me anyway, but thanks Smile

What would be nice: test a debug build on that system with gdb.exe. If you get to IRC, we could set that up. THen we can see where exactly it crashes.

Page 1/5
| 2 | 3 | 4 | 5