openMSX + customkernel

Page 1/3
| 2 | 3

By DarQ

Paragon (1038)

DarQ's picture

05-12-2003, 13:09

hi,

i usually create a custom linux kernel after reinstalling my system. usually, openMSX takes 100% cpu and runs only fine with set frameskip 1.
but recently, i installed debian again and didn't compile a new kernel but used the default kernel. what happened??? openMSX takes 26% cpu @ MAX!!! no frameskip needed...

but here comes the problem..hi,

i usually create a custom linux kernel after reinstalling my system. usually, openMSX takes 100% cpu and runs only fine with set frameskip 1.
but recently, i installed debian again and didn't compile a new kernel but used the default kernel. what happened??? openMSX takes 26% cpu @ MAX!!! no frameskip needed...

but here comes the problem.. it seems that i keep failing creating a decent kernel that doesn't flip to 100% when starting openMSX. what specific config do i need??

thnx in advance!

Login or register to post comments

By Jorito

Mr. Ambassadors (1757)

Jorito's picture

05-12-2003, 14:37

I've noticed that openMSX indeed uses some 70% CPU power on my machine, I've only used custom kernels... However, I'm quite interested in the specifics of a standard Debian kernel to compare, is the kernel config anywhere available without installing Debian?

On a sidenote: I doubt that it's the kernelconfig that's resulting in this slow behaviour, I think that the error (if any) is in the application... I wonder tho... it'd be nice to have openMSX running at an acceptable speed Smile

By DarQ

Paragon (1038)

DarQ's picture

05-12-2003, 15:05

well, i do think it's the kernel config. if i reboot now, with a brand new 2.6.0 kernel, which is fully configured by me, openMSX will run bad. rebooting with the default kernel let's me play with ease and comfort.

but i somehow cannot find the configuration "error" i make. a friend mentioned it could be the lack of "nvidia drivers compiled with the kernel" ?! not sure, never done that before.

By mth

Champion (480)

mth's picture

05-12-2003, 17:24

About the nVidia drivers: these are only necessary to have a fast OpenGL implementation for nVidia cards (used by SDLGL renderer). As long as you use the SDLHi renderer, the XFree86 drivers should work just fine.

I don't know of any kernel options that would impact openMSX performance a lot, but if they exist I'd really like to hear about it. There is one special Linux kernel feature that openMSX uses if available, namely the RTC timer, which is used to get more accurate realtime sync. But that should not have a large impact on the CPU usage.

By DarQ

Paragon (1038)

DarQ's picture

05-12-2003, 18:01

indeed, its not the RTC or SDL timer. with the default kernel RTC cannot be used so it used SDL. with a customkernel it does not really matter. but RTC is slightly better.

ill try to find it

By Manuel

Ascended (15125)

Manuel's picture

12-12-2003, 16:51

However, I'm quite interested in the specifics of a standard Debian kernel to compare, is the kernel config anywhere available without installing Debian?

Sure, when the Debian web site is completely back on line you can just get the sources of all kernel images that are in it. I could also send you my stock kernel config of 2.4.22, if you like.

Very strange that the kernel affects openMSX performance. If we can find the origin of this, we may be able to solve a problem.

Is the CPU usage for both SDLGL and SDLHi affected when you change the kernel?

By DarQ

Paragon (1038)

DarQ's picture

12-12-2003, 18:45

im going to look at it right now.

By DarQ

Paragon (1038)

DarQ's picture

12-12-2003, 18:57

that's funny..

with 2.4.18 (default debian woody kernel)
SDLHi: super smooth! CPU time does NOT exceed 10% with athlon @ 1200
SDLGl: not possible to use the msx decently. it is SOOOO slow at my machine.

with 2.4.22(custom DarQ kernel)
SDLHi: in contradiction to my initial post, i don't need a frameskip at all! but cpu time is always > 97%
SDLGl: still not possible to use it.

hmm, this was my non-info. i recenltly tried finding the configuration that DOES it in the kernel. but still no clue Sad until then, i'll have to use the default kernel.

By Manuel

Ascended (15125)

Manuel's picture

12-12-2003, 20:57

As far as SDLGL is concerned: seems you have no hardware acceleration for openGL programs. Check the output of
glxinfo | grep direct
and
glxgears

(should be 'yes' and some decent framerate >> 100)

I still can't explain the SDLHi differences though...

By DarQ

Paragon (1038)

DarQ's picture

12-12-2003, 21:14

well, it's a big NOTongue i have only a TNT2 Wink framerate is above 200

By Manuel

Ascended (15125)

Manuel's picture

13-12-2003, 13:24

Ah, if direct rendering says "no", then you don't have hardware acceleration. Without it, SDLGL will never work fast. Try to install the nvidia drivers. If you run Debian:
apt-get install nvidia-kernel-source nvidia-glx nvidia-glx-dev
and read the README.Debian of those packages, e.g. in /usr/share/doc/nvidia-kernel-source/README.Debian

Page 1/3
| 2 | 3
My MSX profile