openMSX + Linux

Page 1/2
| 2

By pitpan

Prophet (3131)

pitpan's picture

29-08-2005, 12:18

Hi!

Recently I have migrated to Linux and I have definetly quit WindozeXPhumus. Of course, the first piece of software that I installed was openMSX. The problem is that there is no sound.Hi!

Recently I have migrated to Linux and I have definetly quit WindozeXPhumus. Of course, the first piece of software that I installed was openMSX. The problem is that there is no sound. Apparently everything is fine, and the sound system is working fine both in Gnome and KDE environments.

I have installed the last distribution of Debian Sarge, but I cannot imagine what to do in order to solve this problem. I need sound right now to continue with my projects for MSXdev'05. Please note that I am a total newbie to Linux: n00b from head to toes.

Anyone has experienced the same problem and solved it?

Kind regards,

Edu Robsy

Login or register to post comments

By DarQ

Paragon (1038)

DarQ's picture

29-08-2005, 13:33

do you use alsa??

By ibantxuyn

Expert (96)

ibantxuyn's picture

29-08-2005, 13:33

Hi, Robsy !!

Please post here the output from command 'cat /dev/sndstat'

If you want, mail me to my personal email :-)

Cheers!

alucardX

By DarQ

Paragon (1038)

DarQ's picture

29-08-2005, 13:51

sndstat won't tell you that much if you have a debian config like me. don't know about other distro's but there is no such device in sndstat

By ibantxuyn

Expert (96)

ibantxuyn's picture

29-08-2005, 14:04

I think that /dev/sndstat can print information about ALSA or OSS (now deprecated)...
Also Debian Sarge with kernel 2.6 series must have ALSA enabled and not OSS. There are some wrappers to OSS->ALSA, but I don't tried it.

Other useful command may be cat /proc/asound/cards

Cheers!

alucardX

By ibantxuyn

Expert (96)

ibantxuyn's picture

29-08-2005, 14:08

May be a permission problem, or sound servers, Robsy, you can try openMSX from other windowmanager such as twm ??

1.- login with your normal account
2.- start X window system with xinit
3.- should have a one unique xterm without decorations
4.- execute 'twm &' command to start twm window manager (that SuX xDD)
5.- run openMSX and try again with some ROM

alucardX

By AuroraMSX

Paragon (1900)

AuroraMSX's picture

29-08-2005, 14:21

In openMSX, open the console and check the volume settings of each sound chip. My guess is that these volumes are set to 0.

By pitpan

Prophet (3131)

pitpan's picture

29-08-2005, 17:01

Looking at the /dev contents there is a sndstat, but both with cat or more it says "no such device". Apparently, the sound device is /dev/dsp

About openMSX, it displays the message "Warning: Couldn't open audio: No available audio device". So, it is not a problem of openMSX configuration.

Is there any system to check which sound servers are installed and working?

Yes, I am a total Linux-n00b.

By pitpan

Prophet (3131)

pitpan's picture

29-08-2005, 17:25

Apparently, ALSA hasn't been installed. I installed it (?) and run alsaconfig, but it does not find any sound card. What can I do? What am I doing wrong?

I'm missing my PSG!

By cax

Prophet (3721)

cax's picture

29-08-2005, 17:40

How can it be that "the sound system is working fine both in Gnome and KDE environments" and "No available audio device" goes together ? What makes you think that sound system is working ?

Sound configuration always was somehow problematic on Linux, especially on no-name soundcards that either have no Linux drivers or hard to configure. Tell us more about your soundcard.

By pitpan

Prophet (3131)

pitpan's picture

29-08-2005, 17:49

Well, when KDE boots there is a tune playing, and all the events are also accompanied by sounds and samples. So, what's wrong?

Anyway, I thing that I will reinstall Linux using Ubuntu. Iban has suggested me to do so, and I think that it is a good idea. I hope that this will fix the different configuration problems that I am experiencing at the moment.

Page 1/2
| 2
My MSX profile