oooh yeaaahh i need glasses

By flyguille

Prophet (3029)

flyguille's picture

19-06-2004, 17:27

By [D-Tail]

Ascended (8233)

[D-Tail]'s picture

19-06-2004, 22:11

Which indicates you don't use a decent web browser: I use Mozilla Firefox Smile.

Get your *free* copy :) HERE :).