puertos de joystick no funcionan en Sony HB-F9P

Par romanilla

Rookie (27)

Portrait de romanilla

03-05-2015, 17:16

Hola!

recientemente me di cuenta que los ports de mi Sony HB-F9P no funcionaban. Concretamente sólo funciona alguna dirección, y sólo a veces. El joystick funciona ok (he jugado con él en mi otro MSX), y al abrir el ordenador para inspeccionar los componentes no veo nada raro alrededor de los puertos de joystick, y las conexiones y resistencias relacionadas están bien.

Alguien me podria guiar en qué otras cosas podria inspeccionar??

GRACIAS!

!login ou Inscrivez-vous pour poster

Par Bothman

Champion (500)

Portrait de Bothman

07-05-2015, 12:34

A mi me pasó exactamente igual en un HB-F9S, y aparentemente estaban bien (los puertos no estaban holgados y visualmente no se apreciaba daño de ningún tipo). Lo llevé a un servicio de Sony y resultó que hubo que estañar de nuevo las conexiones de los puertos.
Si no es eso, como no sea algún tipo de "controlador" que se haya frito... de hardware no tengo ni papa.

Par anonymous

incognito ergo sum (116)

Portrait de anonymous

07-05-2015, 13:33

Par ENDDEMOGAMITAINA

Paragon (1279)

Portrait de ENDDEMOGAMITAINA

07-05-2015, 23:12

Es un clasico,puede ser solo estañar las soldaduras,o lo peor...que tenga pines rotos en la distancia interna del conector...donde no s epueden ver...,en ese caso se puede cambiar la pieza entera por la de cualquier ordenador...desde un AMSTRAD o un ATARI...cualquiera...,
si fuera tema de alguna direccion o boton pulsado entonces podria tratarse de un Integrado fundido.
saludos.

Par Bothman

Champion (500)

Portrait de Bothman

12-05-2015, 15:17

Por curiosidad, ¿cómo ha ido?

Par romanilla

Rookie (27)

Portrait de romanilla

17-05-2015, 23:51

Hola!

aún no me he vuelto a meter en ello, pero sospecho a bien que el controlador está fundido o bien el joystick que tengo no hace buen contacto con los puertos de este MSX (en otro funciona perfectamente). Lo digo porqué de vez en cuando, y si muevo el conector, funciona alguna dirección. Conectare pin a pin a un botón y a masa para probarlos.

Gracias por las respuestas!

Par anonymous

incognito ergo sum (116)

Portrait de anonymous

18-05-2015, 08:19

No te líes y ve al grano, si mueves el conector y funciona ten claro que son las soldaduras rotas, te lo digo por experiencia como otros ya comentan aquí. El problema suele ser básicamente este, aunque es posible que se haya arrancado parte de alguna pista con lo que deberás puentear en ese caso. Piensa es un conector que no está bien reforzado en este modelo, avería típica en él, y de tanto meter y sacar el joystick se acaba estropeando.

Además si el joystick funciona en otros, descarta el que los pines no hagan buen contacto...

Par AxelStone

Prophet (3019)

Portrait de AxelStone

18-05-2015, 14:12

Un clásico, mi F9S tuvo el mismo fallo y se "arreglaba" moviendo el conector. Básicamente soldaduras malas, este modelo es muuuy sensible.

Par ENDDEMOGAMITAINA

Paragon (1279)

Portrait de ENDDEMOGAMITAINA

18-05-2015, 22:39

A un chico que conocia le salio de un rastro un F9S con este fallo,ya me dejo uno igual anteriormente y se lo repare,
pero este ultimo no habia forma,le repasaba las soldaduras y nada...,seguia sin funcionar,
lo que descubri probando y probando fue que las pistas estaban rotas,pero no en la PCB,si no en conector,
no llegaban a la PCB,es una averia muy traidora,pero al menos es facil de arreglar,
menuda chapuza le lie,le desolde el conector y le empalme cable a cable uno de otro MSX,un Sanyo MSX1 que tenia para piezas...,
no podia recolocar el port por que unos plasticos me impedian colocarlo...,fisicamente no cabia.
asi que lo monte cable a cable y lo bañe bien en silicona.
romanilla revisa a ver si puede ser eso,si tienes maña puedes resolverlo de formas mas elegantes eso esta claro.
saludos.