ARKANOID en MSX1 ML-FX1 no funciona.

Page 1/3
| 2 | 3

Par Damanium

Supporter (9)

Portrait de Damanium

06-06-2016, 21:38

¡Muy buenas! Question

Es mi primer post por aquí y me encuentro con un problema muy raro a la hora de intentar cargar un archivo convertido con el CAS2WAV, en este caso es el mítico ARKANOID.
Deciros previamente que he conseguido cargar muchos juegos en mi ML-FX1. El sistema que utilizo es muy tradicional:

Convierto el archivo CAS a WAV con el CAS2WAV y MUY IMPORTANTE, edito el WAV con AUDACITY y le añado algo menos de 2 segundos de la parte de la ONDA PLANA que se encuentra generalmente entre los segundos 8 - 10 del WAV resultante, como con un copia-pega no es suficiente tiempo, lo pego 2 veces al final de la onda. Esto lo aprendí al preparar los archivos para mi Spectrum 128+, si no realizas esta operación la carga fallará por que el equipo se queda esperando el final del archivo.
Paso el WAV a un MP3 y, Big smile ahora viene lo mejor, Big smile conecto una cassete al MP3 y lo introduzco en el lector de cintas del MSX. Despues de este paso, a cargar como si fuese una cinta para MSX normal y corriente.

Pues bien, con este sistema me carga prácticamente todo, pero el ARKANOID es imposible, a los 20 o 30 seg. se para el lector de cinta. He probado cargando diferentes CAS del ARKANOID y todos con el mismo resultado. Solo he conseguido llegar hasta el final de la carga introduciendo POKE-1,170, pero no aparece nada durante la carga de la misma y al final, pantalla en negro, logo de MSX inicial y pantalla en negro otra vez.

Agradecería si alguien pudiese ayudarme con esto por que por mas vueltas que le doy o consigo hacer que funcione.

He probado con:
RUN"CAS:"
BLOAD"CAS:",R

He repetido la operación en ambos tipos de carga introduciendo POKE-1,170 antes de cargar la cinta y llega hasta el final pero la pantalla se queda parada en FOUND:ARK y cuando llega al final de la carga, pantalla en negro y vuelta al logo inicial del MSX para luego volver al negro de nuevo.

¡Un saludo!

!login ou Inscrivez-vous pour poster

Par Panzer

Paragon (1041)

Portrait de Panzer

06-06-2016, 22:51

Hola, Damianum.
Podría estar incluso hasta mal dicho wav.
De todos modos no utilices el POKE-1,170
Prueba con POKE -1,(15-PEEK(-1)\16)*17
Salu2.
Panzer.

Par tranx

Champion (341)

Portrait de tranx

06-06-2016, 23:12

La ostia, menudo poke !

Me pregunto si ese poke tan potente hubiera arreglado todos los problemas que daba mi VG8020 al cargar juegos

Par Panzer

Paragon (1041)

Portrait de Panzer

07-06-2016, 08:29

Hola, tranx.
El problema está en como se gestionan los subslots.
Los juegos en cinta pueden estar mal programados.
Y hay conversiones a cas no están bien realizadas...
El famoso poke-1,170 cambia dicha configuración...
Pero como puede variar con la máquina mejor usar...
... el poke "universal" POKE -1,(15-PEEK(-1)/16)*17
No es necesario hacerlo siempre, basta con una vez...
Por ejemplo en mi ML-G3, print peek(-1) devuelve 95
Es el valor de la configuración previa, sin "corregir"...
Tras el POKE -1,(15-PEEK(-1)/16)*17, nos devuelve 101
Luego el valor a recordar para otra vez es poke-1,101
Y ya tendremos configurada la gestión de los subslots.
Lo cual no quita para que con poke-1,170 también vaya.
De hecho con este ordenador va con el 170 y con el 101.
Pero evidentemente, no van ciertos juegos con dicho 95.
Un saludo.
Panzer.

Par osises

Master (214)

Portrait de osises

07-06-2016, 08:37

Hola. Por si te sirve de ayuda, este fué el primer MSX que tuve. Recuerdo que en su momento tuve este juego de una versión que se comercializó en un pack, creo que también estaba Head over Heals.

Siempre funcionó correctamente, sin nada más que cargar el juego de manera estandar. Si no recuerdo mal, para este modelo el valor para poke -1 es 170, es decir poke -1,170. A este juego no hace falta indicar nada para este poke, ya que, si no estoy equivocado, eso es únicamente para juegos japoneses y poco más (creo que los convertidos de cartucho).

Espero sirva de ayuda.

Par Panzer

Paragon (1041)

Portrait de Panzer

07-06-2016, 08:43

Por otro lado, Damanium, hay algo que me despista del todo.

Damanium wrote:

Paso el WAV a un MP3 y, Big smile ahora viene lo mejor, Big smile conecto una cassete al MP3 y lo introduzco en el lector de cintas del MSX. Despues de este paso, a cargar como si fuese una cinta para MSX normal y corriente.

Entiendo que copias el fichero .wav a un reproductor MP3...
No conviertas el formato .wav a .mp3 pues pierde calidad...
El conecto una cassete al MP3 será un adaptador como este...

... que introduces en el "lector de cintas" que sueles usar...
Pues bien, creo que debes ahorrarte ese juego de malabares...
Conecta directamente el reproductor de MP3 al cable del MSX...
La calidad será evidentemente muchíiiiiiiiiiiiiiiiiiisimo mejor...
Un abrazo.
Panzer.

Par Panzer

Paragon (1041)

Portrait de Panzer

07-06-2016, 08:50

Hola, Osises.
En mi ML-G3 o pongo el poke -1,170 o el arkanoid no va...
No el de cinta, que siempre ha funcionado correctamente...
... sino los "convertidos" con el cas2wav o con el waver...
Si no, busca el wav patanegra, copia exacta del original...
Es una pena que Pablibiris haya "cerrado" su "proyecto"...
Salu2.
Panzer.

Par Damanium

Supporter (9)

Portrait de Damanium

07-06-2016, 19:38

Si, en efecto. Conecto el reproductor MP3 a una cinta como la de la foto la cual esta introducida en un lector DATA RECORDER con su REM y toa la pesca (tres cables). Lo hago así por que no quiero meter la clavija mono en el puerto estéreo del MP3 por precaución. Si me dices que no pasa nada puedo probar a saltarme el DATA RECORDER.

No paso nada a MP3, lo dejo en WAV.

Par Panzer

Paragon (1041)

Portrait de Panzer

07-06-2016, 20:17

No tengas miedo.
No pasa nada por poner el mono en el estereo.
Evidentemente, el sonido saldrá solo en mono.
Además, ni el mic ni el rem pueden funcionar...
Prueba eso primero y si no, prueba lo del poke.
Salu2.
Panzer.

Par Damanium

Supporter (9)

Portrait de Damanium

07-06-2016, 20:33

Buenas, os sigo contando:

Con el POKE -1,(15-PEEK(-1)\16)*17 hace exactamente lo mismo, llega hasta el final se pone la pantalla en negro, después la de inicio de MSX y otra vez al negro, es necesario apagar el equipo.

Esto ocurre tanto si utilizo RUN"CAS:" como BLOAD"CAS:",R

Serie interesante poder conseguir ese "WAV patanegra" que menciona Panzer por que creo que la versiones CAS que yo he podido encontrar, tras búsquedas exhaustivas, son de la versión japo.

De momento sigue sin funcionar oO

¡Saludos!

Par Damanium

Supporter (9)

Portrait de Damanium

07-06-2016, 20:41

Panzer wrote:

No tengas miedo.
No pasa nada por poner el mono en el estereo.
Evidentemente, el sonido saldrá solo en mono.
Además, ni el mic ni el rem pueden funcionar...
Prueba eso primero y si no, prueba lo del poke.
Salu2.
Panzer.

Probado, el MSX ni se inmuta (entiendo que el cable que he de conectar es el ROJO ("Out" del DATA RECORDER), me imagino que ni se inmuta por la poca ganancia del reproductor MP3.

Es rarisimo por que he convertido un montón de CAS con el CAS2WAV y todas funcionan, esta en particular se me resiste Crying

Page 1/3
| 2 | 3