RoboPlay update 1.2 released

RoboPlay update 1.2 released

par ToriHino on 13-10-2020, 17:08
Sujet: Music
Étiquettes: opl4, roboplay, MIDI, SCC
Langues:

A new update of RoboPlay is released with also support for the SCC chip.

Updates for 1.2:

  • MIDI: standard MIDI files using either FM or OPL4 WaveTable playback (WaveTable needs a fast MSX)
  • SCC: support for SCC Musixx and SCC Blaffer NT fileformats

Binaries of latest version can still be downloaded from this location.
Also updated the RoboPlay Starter pack with a number of SCC based songs, which you can find here.

Currently so far the following file formats are supported:

For OPL4:

  • SOP: Note OPL3 Music Sequencer
  • D00: EdLib packed module
  • DRO: DOSBox Raw OPL v0.1 and v2.0
  • RAW: Rdos Adlib Capture
  • MOD: Amiga Module (up to 24 channels)
  • VGM: Video Game Music
  • IMF: iD Software Music Format (for .WLF extension 700Hz replay is used)
  • MBM: MoonBlaster 1.4 (inlcuding PSG drums, ADPCM sample support)
  • MUS: FAC SoundTracker 1.0, 2.0 and PRO (stereo replay, ADPCM sample support)
  • PRO: Tyfoon Pro-Tracker (stereo replay)
  • MID: Standard MIDI file (WaveTable or FM)

For SCC:

  • SBM: SCC Blaffer NT (including PSG drums)
  • SNG: SCC Musixx

Project location and source files can be found here.

Commentaires (16)

Par Gloriou

Master (181)

Portrait de Gloriou

14-10-2020, 16:45

Great! Thank Guys
Can't wait to try it Smile

Par Pac

Guardian (5924)

Portrait de Pac

14-10-2020, 17:24

Great work! The ultimate MSX sound player. Wink

Par The Apeman

Expert (89)

Portrait de The Apeman

15-10-2020, 15:41

How fast is a "fast MSX?" 7Mhz? R800?

Par ToriHino

Hero (602)

Portrait de ToriHino

15-10-2020, 17:19

The Apeman wrote:

How fast is a "fast MSX?" 7Mhz? R800?

R800 still has sometimes problems with certain MIDI files now so I think in general that's currently the minimum (did not try much on different configurations yet though). It really depends on the complexity of the MIDI file.
I also think there is still room for performance improvement (it's also completely in C now) so will continue to look into that.

Par msd

Paragon (1405)

Portrait de msd

18-10-2020, 12:55

I’ve created an asm lib to play the OPL4 gm instruments , I could send it to you. Perhaps you can use it or use it as inspiration .

Par msd

Paragon (1405)

Portrait de msd

18-10-2020, 14:44

@torihino. The opl4 is you might know as very sensitive register timing. In the sense that you have to respect the timing between out instructions. When i was working on the mbwave drivers I made sure it worked on 7.16MHz systems by checking these timings. The turbo r version used a push bc pop bc between every out instruction. What did you do to check this timing in roboplay?

Par ToriHino

Hero (602)

Portrait de ToriHino

18-10-2020, 15:34

I'm indeed interested in your asm lib for playing the OPL4 instruments, I think current implementation is still far from optimal Smile. You can send it to torihino at Google's mail if you want to.

For timing I use either the BUSY flag when writing to registers or the LOAD flag when loading data in the wave table. I always test at least on my Turbo-r, sometime also on my MSX 2+. Most likely for regular Z80 most of the waiting is overkill, but so far I did not make any exception for it.

Par msd

Paragon (1405)

Portrait de msd

18-10-2020, 16:25

@torihino. Send it , if you don't receive then i failed to decipher your email address Tongue

Par ToriHino

Hero (602)

Portrait de ToriHino

18-10-2020, 16:52

Yes got it, thanks. Will take a look at it.

Par roadfighter

Champion (404)

Portrait de roadfighter

28-10-2020, 16:11

Does anyone else have some problems to get Roboplay to work?
I have put Roboplay in my Autoexec.bat like set roboplay=a:\music\roboplay\
Then when I start a music file in a:\music\mbmfiles\ I get the following message:
free mem: 352k
loading player: a:\music\roboplay\mbm.ply .....Done
(Chinese)

.......Done
.......Done
.......Done

Then absolutely nothing at all. no sound what so ever and my MSX hangs.

Also when using a file from the file pack with the x.D00 extension i get:
loading player: a:\music\roboplay\d00.ply .....Done
(Chinese)

.......Done
.......Error
Not a valid file for this player

*** Internal error

So please HELP looks like a great player but till now no sound....
Used MSX, Turbo-r GT with original moonsound 1024kb and Megaflashrom.

Par ToriHino

Hero (602)

Portrait de ToriHino

28-10-2020, 17:39

Hi roadfighter,

THere is no longer the need to use "set roboplay=...", it now looks for players in the same folder as the main program. It might be that it now somehow finds older (not compatible) players, thats might explain why you get the "Chinese" :-).

Can you try again with the latest version from here?
Just unzip it to a folder and make sure any older installation is removed (also remove the set roboplay= ).

No further settings are needed, testing it on a real Turbo-r ST with moonsound and MFR gave no problems.

Par roadfighter

Champion (404)

Portrait de roadfighter

28-10-2020, 18:28

Don't i need the set roboplay= for redirecting it to roboplay.com?
My files are in different directory's. Or do i put it in autoexec with path a:\music\roboplay\ ?
But i am going to try later this evening, thanks for the quick response.

Par ToriHino

Hero (602)

Portrait de ToriHino

28-10-2020, 18:56

No, the set roboplay= was only needed in earlier releases. You can put in autoexec the path to a:\music\roboplay\ (if that's where you install it) so that you can start it from anywhere. But it will always find the player files, no matter from where you start it (so also in a different directory).

Par roadfighter

Champion (404)

Portrait de roadfighter

28-10-2020, 21:17

Thanks ToriHino, for the great program and all in one solution. Question the midi files are they only played trough the opl4? Or is the midi itself also played trough a midi port from the turbo-r or other cartridge? I like to play midi files and if roboplay could do both that would be great.
Keep up the great work.

Par ToriHino

Hero (602)

Portrait de ToriHino

28-10-2020, 21:26

Currently it only plays on the opl4 (or FM). Maybe a future extension to also send it to the MIDI port Smile

Par Robosoft

Expert (85)

Portrait de Robosoft

29-10-2020, 13:31

roadfighter wrote:

Thanks ToriHino, for the great program and all in one solution. Question the midi files are they only played trough the opl4? Or is the midi itself also played trough a midi port from the turbo-r or other cartridge? I like to play midi files and if roboplay could do both that would be great.
Keep up the great work.

You could use Robomidi, a commandline player wich uses the Philips Music module midi ports.

Download it here