SVI-738 goes unstable and crashes after warming up.

Page 1/2
| 2

Par protek

Expert (119)

Portrait de protek

31-10-2021, 17:00

I wonder what might cause the unstablity in my 738 when it warms up?
When it’s completely cold, it’ll boot nicely, I can enter the time when prompted and go to the basic prompt. In less than a minute the picture begins to deteriorate, showing flashing pixels and and going wavy. Soon after that, it reboots and no longer responds to the keyboard. It’ll take a cooldown period before it’ll boot intoa stable picture.

Some component is failing when it’s warming up, but what could it be? I’ve changed all the electrolytics except the big 470 uF, which seems to be glued onto the mainboard.

!login ou Inscrivez-vous pour poster

Par protek

Expert (119)

Portrait de protek

31-10-2021, 17:05

Par lkpalwa

Expert (112)

Portrait de lkpalwa

09-11-2021, 16:58

RAM issues ? try to exchange VRAM and RAM, looks like the issue I have seen on c64 machine with bad ram

Par protek

Expert (119)

Portrait de protek

25-11-2021, 20:25

I’ve already swapped the VRAM and I’ve now removed the DRAM. Will put sockets and new DRAM chips tomorrow.

Par S0urceror

Master (195)

Portrait de S0urceror

26-11-2021, 08:46

I see image detoriation so I suspect the video circuit or the video chip itself. Ram/ROM would just freeze the MSX.

If you quickly type a program that plays some music in a loop I would be interested if the music keeps playing when the screen is lost. That would show the machine stills works but the video has died.

Par sdsnatcher73

Prophet (2535)

Portrait de sdsnatcher73

26-11-2021, 13:17

Or if you have a game cartridge which plays a demo (like Nemesis series) with music you can see if the music keeps playing. It’s my way of detecting bad LVA510 chips on Toshiba HX-10 Wink

Par sdsnatcher73

Prophet (2535)

Portrait de sdsnatcher73

26-11-2021, 13:17

Or if you have a game cartridge which plays a demo (like Nemesis series) with music you can see if the music keeps playing. It’s my way of detecting bad LVA510 chips on Toshiba HX-10 Wink

Par Jipe

Paragon (1528)

Portrait de Jipe

26-11-2021, 14:44

On SVI-738 manual service you can see the RGB to composite converter is a MC1377 (IC64)
the power supply of this chip is 12V on pin 14 & 15
check if this chip is warm and if the 12V is stable

Par protek

Expert (119)

Portrait de protek

26-11-2021, 20:46

^I’ll check the voltages to the composite converter. I do have spares, although I doubt a dodgy composite converter would crash the whole machine. I’ve got a few game carts but my bench doesn’t have anything to play audio out of. I do know the machine crashes as it reboots while a cart is being inserted. Not straight away but after 5 to 10 minutes. I’ve got a second replacement VDP on its way.

Par protek

Expert (119)

Portrait de protek

10-01-2022, 20:08

Turns out the first replacement V9938 was marginal. With the second replacement it’s now working stably.

Par Grauw

Ascended (10312)

Portrait de Grauw

10-01-2022, 20:29

Thanks for the update! Always nice to get some closure.

The issues in the screenshots are so weird, it certainly makes sense that it was related to the VDP itself. But did you have the same issue with both the original VDP as well as the first replacement? Suspicious…

Page 1/2
| 2