Loading games from tape

ページ 1/4
| 2 | 3 | 4

By protek

Expert (116)

protek さんの画像

04-02-2013, 06:34

I'm trying out the datassette that I got for my SVI-728. Had to do a bit of refurbishing in order to be able to start playing with it. The problem at the moment is that I doesn't appear to load any games. I've got a few original tapes which I've tried to load according to the instructions. The relay switches the datassette motor on via remote and I've verified that the data is "played" with a pair of ear plugs. However, I don't seem to get any kind of feedback on the screen. No "found" or loading screen or anything and I've played the tape a few minutes. How do original games usually load on MSX? I've tested the cable with a multimeter. Didn't have a pinout at hand, when I tested the continuities so not sure about which plug is supposed to go where. At the moment the white plug goes into ear/output and the red into mic/input.

ログイン/登録して投稿

By mars2000you

Enlighted (6019)

mars2000you さんの画像

04-02-2013, 09:52

Command 	  	 
RUN"CAS:" 	  	For MSX-BASIC files saved with SAVE
BLOAD"CAS:",R 	  	For binary files saved with BSAVE
CLOAD	  	        For MSX-BASIC files saved with CSAVE - 
                                After loading of the file, press on F5 to run it 

By pitpan

Prophet (3145)

pitpan さんの画像

04-02-2013, 10:30

WHITE / EAR jack from the MSX cassette cable should be plugged to the cassette output, DATA OUT. In any case, check first if there is a problem with the computer and/or cable. Use a reliable sound source, such as a PC computer, and replay a WAV file with MSX content (plenty of sites around). Play with the volume until it loads (or not). If it works, then it is a problem related to the cassette: check again volume, adjust the headers, etc.

By protek

Expert (116)

protek さんの画像

04-02-2013, 11:37

Thanks! I'll try with the music player of my mobile phone. I've managed to load games on my Spectrum with it.

Do the original games have a loading screen like the C64 and Spectrum?

By Manuel

Ascended (18256)

Manuel さんの画像

04-02-2013, 14:48

Depends on the game. Most have one. Which games are you trying?

By protek

Expert (116)

protek さんの画像

05-02-2013, 22:41

I've got Batman, Lazy Jones, World Games and a few others.

Tried playing a WAV file through my mobile phone. The 728 didn't find anything from that either. The cable is OK as I measured continuities again. The white plug does go to CMTIN. Does this mean that there's something wrong with the 728?

By Manuel

Ascended (18256)

Manuel さんの画像

06-02-2013, 22:16

Which loading instruction did you use for each game?

By protek

Expert (116)

protek さんの画像

08-02-2013, 05:30

I think all that I tried had bload"cas:",r in their instructions.

By Manuel

Ascended (18256)

Manuel さんの画像

08-02-2013, 18:09

OK, maybe you can make a movie showing what's happening. Then we can see that you did everything correctly.

By protek

Expert (116)

protek さんの画像

13-02-2013, 08:52

Maybe I'll try saving a short basic program on tape and try loading that. Helps to rule out azimuth angle.

By protek

Expert (116)

protek さんの画像

22-11-2013, 09:42

Dusting this old thread.
Bought another SVI-767. This time a model with fixed datacable. I had slightly better results with this as I managed to get "found" message before getting "device i/o error".
I also tried by playing a 2400baud wav from my phone's audio player using a separate cable but that didn't find anything. I've checked the continuities of the separate cable with multimeter, when I fixed the remote lead so that should be ok.

ページ 1/4
| 2 | 3 | 4