Ремонт MSX1 (Yamaha CX5MU)

By tnt23

Master (149)

tnt23의 아바타

07-12-2010, 19:00

Приехал заказанный TMS9918A, поставил я его и не заметил разницы. То есть он меньше греется, чем его предшественник, но и все.

На какие-то секунды показалось, что при включении на экране возник трудноразличимый логотип и надпись под ним, и все. Больше это не повторялось.

Соответственно я грешу теперь на видео-RAM. Она в CX5M построена на 16Кх1 чипах, причем с тремя питаниями (+5в, -5в и +12в). Попытаться заменить на какие-нибудь РУ6 с учетом неиспользуемых под питание выводов?

Login or 등록 to post comments

By Eugeny_Brychkov

Paragon (1145)

Eugeny_Brychkov의 아바타

08-12-2010, 08:26

Начни с того, как она (машинка ) умерла, и что могло служить этому причиной.

By tnt23

Master (149)

tnt23의 아바타

08-12-2010, 08:39

К сожалению, я не присутствовал при её кончине Smile Со слов очевидца, был скачок напряжения в сети, после чего пропал видеосигнал, и стал сильно греться VDP. Последний был выпаян и поставлен в панельку, но легче ему не стало. С тем машинка ко мне и приехала.

Сегодня постараюсь взглянуть на VDP (и на остальное) через осциллограф.

Вопрос - что при включении должно появляться на экране MSX1 до приветствия BASIC?

By Eugeny_Brychkov

Paragon (1145)

Eugeny_Brychkov의 아바타

08-12-2010, 09:06

Осциллографом смотришь следующие выводы:
33 - +5v
39 и 40 - XTAL
38 - CPUCLK
1, 2 и 3 - /RAS, /CAS и /W
Появляться ничего не должно. Возможно при включении - при появлении композитного сигнала - пустой экран "взрогнет".

By Eugeny_Brychkov

Paragon (1145)

Eugeny_Brychkov의 아바타

08-12-2010, 12:08

1, 2 и 3 - /RAS, /CAS и /W
1, 2 и 11

By tnt23

Master (149)

tnt23의 아바타

08-12-2010, 13:24

Я еще посмотрю, есть ли что на выводах 35 и 36. По идее, чтобы VDP начала давать какое-то подобие развертки, нужно, чтобы ее кто-то настроил.

http://www.msxarchive.nl/pub/msx/docs/service_manuals/yamahacx5musm.pdf

By tnt23

Master (149)

tnt23의 아바타

08-12-2010, 15:11

Занятно!

На всех проверенных выходах были осмысленные сигналы. Более того, на видеовыходе тоже обнаружился нормальный композитный сигнал! похоже, я просто спалил себе композитный вход в TV-тюнере, поэтому ничего и не видел Smile

Сделал на скорую руку переходник в S-Video, и увидел синий фон с белыми буквами. Ура! новая VDP оказалась живой, и вроде бы VRAM тоже выжила.

By Eugeny_Brychkov

Paragon (1145)

Eugeny_Brychkov의 아바타

08-12-2010, 15:45

А старый?

By tnt23

Master (149)

tnt23의 아바타

08-12-2010, 15:54

SFG-05 тоже работает, но смущает некоторый мусор вверху экрана:

http://images16.fotki.com/v3/photos/1/1349988/6372796/08174924-vi.jpg

Возможно, подпортилась ROM в SFG.

By tnt23

Master (149)

tnt23의 아바타

08-12-2010, 16:06

Старый пробовать не стал даже, да и комп на радостях уже собрал Smile