Full screen by command line in openmsx

By walterg74

Supporter (7)

walterg74의 아바타

24-04-2021, 02:31

Hi Folks,

New here and trying out openmsx.

While I realize there is catapult, I am building emulation setups of different computer systems and like to just have some batch files to click and have different systems pop up.

While I made some simple batch files for openmsx and different machines and they do appear, what I tried to force full screen on startup does not seem to work, finding instead that openmsx simply starts up in the state (windowed vs full screen) that was last used.

Is my command wrong, and is there an actual way to force it?

I'm using something like this:

openmsx.exe -machine Panasonic_FS-A1GT -command "set fullscreen"

Thanks!

Login or 등록 to post comments

By santiontanon

Paragon (1522)

santiontanon의 아바타

24-04-2021, 07:02

Hi walterg74, notice that according to the manual ( https://openmsx.org/manual/commands.html#fullscreen ), you need to do "set fullscreen on"

By walterg74

Supporter (7)

walterg74의 아바타

25-04-2021, 00:01

Wow.. do I feel stupid...

How did I miss that, being it's the exact same place I found what command to add... Oh well, thanks a million, they all work great now!! Smile

Only thing to "fix" now is my OCD that wants all supported machines to work and have some machines and some extensions reported not working. I downloaded the pack at the known site, updated recently but I guess some are not correct?

By Manuel

Ascended (18238)

Manuel의 아바타

25-04-2021, 00:32

Which are not working, asks my curious inner self?

By walterg74

Supporter (7)

walterg74의 아바타

25-04-2021, 01:06

Manuel wrote:

Which are not working, asks my curious inner self?

Got the pack from msarchive.nl, main page, file dated April 7th, and using openMSX 16. According to catapult these do not work:

machine: Acid1Test-slots
machine: Acid2Test-hardware
machine: Boosted_MSXturboR_with_IDE
machine: Yamaha_CX11
machine: Yamaha_CX5F
machine: Yamaha_CX5M

extension: ASCII_Japanese_MSX-Write_II
extension: Beer_IDE
extension: Boosted_audio
extension: ide
extension: nowind
extension: Philips_VY_0010
extension: Sanyo_MFD-001
extension: SensorKid
extension: Spectravideo_SVI-707
extension: Toshiba_HX-F101PE
extension: Yamaha_FD-03
extension: Yamaha_SFG-01

Browsing the forum randomly I saw folks with all working, so probably something on my end?

By walterg74

Supporter (7)

walterg74의 아바타

25-04-2021, 01:17

Manuel wrote:

Which are not working, asks my curious inner self?

Well, hang on... user error again...

While I did notice that the machines folder from that file didn't go into the actual machines folder but in systemroms, seems I did not do the same with the extensions... So some machines that use extensions were being reported as not working simply because the roms were not there. I just moved them and now it's *almost* all good Smile

There is just 1 reported not working now,:

machine: Boosted_MSXturboR_with_IDE

Troubleshooting why....

By walterg74

Supporter (7)

walterg74의 아바타

25-04-2021, 01:36

Aaaaaand user error again of course, this time with ide250, which I guess it doe snot look for in the .zip file and needs to be in a folder.

Now it really is all good Murdoch

Thanks all!

By santiontanon

Paragon (1522)

santiontanon의 아바타

25-04-2021, 04:12

hahaha, great to read that everything is working now Smile

By Manuel

Ascended (18238)

Manuel의 아바타

25-04-2021, 10:23

You should be able to unzip that pack in share/systems and that's all.

By walterg74

Supporter (7)

walterg74의 아바타

25-04-2021, 23:06

santiontanon wrote:

hahaha, great to read that everything is working now Smile

Thanks!

By walterg74

Supporter (7)

walterg74의 아바타

25-04-2021, 23:09

Manuel wrote:

You should be able to unzip that pack in share/systems and that's all.

Yep, did that and all is good in the world again Big smile

Now All I need to do is find out how to convert the CPM disks I obtained for one of my favorite machines (SVI 738 X'press) from the .IMG file I see to .DSK to use with openMSX...