Issues loading own basic programs on real hardware

By Code Witcher

Resident (43)

Code Witcher의 아바타

20-10-2021, 04:25

Hi guys,
I use csave to save my basic programs, then I use cload to load it, simple enough. I record the wavs in my laptop.
I'm now trying on a new msx that I got and this doesn't work with my own programs, it does work if I want to load games or cas files, but not programs that I saved using CSAVE.
What could I be doing wrong? I tested different volume levels and nothing.

Login or 등록 to post comments

By Manuel

Ascended (18392)

Manuel의 아바타

20-10-2021, 09:54

Are you saying it worked with your previous MSX (which?) and not with your new MSX (which?)?

By Code Witcher

Resident (43)

Code Witcher의 아바타

20-10-2021, 15:18

It worked on my dpc-200.
Now I'm using a tpc-310 (msx2 from Argentina).
I'm guessing it's the audio format, but I don't know. I tried compressed formats mp3 and m4a, and with several uncompressed wav formats, even stereo and mono, different volume levels... it's so strange.
There doesn't seem to be anything wrong with the cable, stuff loads from my android phone using that great app msx2cas.

By Code Witcher

Resident (43)

Code Witcher의 아바타

20-10-2021, 15:26

Ok I tried other wavs downloaded from file-hunter, they work, so I have to check what formats those are in...

By Code Witcher

Resident (43)

Code Witcher의 아바타

20-10-2021, 15:57

Ok I found the issue.
What the laptop plays the msx doesn't recognize, but I moved this audio file to my cellphone, and I could CLOAD it from it.
It must be something with the jack, probably my laptop doesn't like the mono jack from the original datassette cable?

By sdsnatcher73

Prophet (2533)

sdsnatcher73의 아바타

20-10-2021, 16:17

Ah you need a stereo to mono converter for this (otherwise the connection is not stable).

By Code Witcher

Resident (43)

Code Witcher의 아바타

20-10-2021, 16:37

I see! And what about this wav file? I used to load it from my cellphone a few years ago, now the msx gives me a "device error after a few seconds", instead of "found".
https://drive.google.com/file/d/1F7WTs_JiQf4lgorr7DgRqVuidkV...

By Manuel

Ascended (18392)

Manuel의 아바타

20-10-2021, 23:00

Hmm, it loads fine in openMSX at least, so the data seems OK.

By CASDuino

Master (253)

CASDuino의 아바타

21-10-2021, 20:21

Manuel wrote:

Hmm, it loads fine in openMSX at least, so the data seems OK.

I did the same on Facebook with him. The volume is probably the issue.