"Joystick left" won't work - MSX2 NMS VG-8235

Pagina 1/2
| 2

Door 800XL

Supporter (9)

afbeelding van 800XL

28-04-2012, 23:26

Hello all!

I'm new to this group and will start right off with a question if you don't mind. Wink

So I got an MSX2 Philips VG-8235 off of ebay, connected it to my SD-Floppy-Emulator and it works like a charm - except for Joystick 1 left movements. Sad

Up, down, right and fire are fine, though. Is this a common problem? Google wasn't my friend in this case.

(Joystick 2 is fine in all directions.)

Any help?

Thanks,

800XL

Aangemeld of registreer om reacties te plaatsen

Van kanima

Master (192)

afbeelding van kanima

29-04-2012, 00:37

I used to have a VG-8235 back in the days and never had any joystick problems. If the same joystick works fine in port 2 then there very probably is a hardware problem with port 1. Just to make sure it isn't caused by your SD-Floppy-Emulator you might want to test the joystick port in BASIC in bare bones mode (no cartridges, SD interfaces, emulated floppies etc)...

To test both joystick ports, just enter and then RUN the following BASIC program:

10 PRINT STICK(1),STICK(2)
20 GOTO 10

This will continually print the joystick direction of port 1 and port 2. 0 means no direction, 1 is up, 2 up-right, 3 right, 4 down-right, 5 down, 6 down-left, 7 left, 8 up-left.

Van 800XL

Supporter (9)

afbeelding van 800XL

29-04-2012, 01:00

Thanks for your reply, kanima, I already tried this. Joystick 2 is okay, left on JS 1 won't work. I even disconnected the SD-Floppy for good measure. Maybe a cold solder joint? Will have a look at this tomorrow, but I'm clueless when it comes to soldering... Sad

Van Manuel

Ascended (15680)

afbeelding van Manuel

29-04-2012, 12:06

Bas once taught me that this is most likely a broken MSX-ENGINE....

Van anonymous

incognito ergo sum (109)

afbeelding van anonymous

01-05-2012, 01:40

Check the solders, these kind of connectors (plug-unplug) suffer mechanical stress.

Van Gradius2

Hero (574)

afbeelding van Gradius2

01-05-2012, 03:59

I agree to PAC, it might be just a broken joint or went bad.

Van 800XL

Supporter (9)

afbeelding van 800XL

01-05-2012, 10:54

Thanks for all your replies. I will tear the thing apart this afternoon an will report back. Problem is, I'm pretty useless spotting bad joints let alone wielding a soldering iron. LOL!

Van Jipe

Paragon (1366)

afbeelding van Jipe

01-05-2012, 12:34

I already had between the hands one 8235 with the same breakdown
sorry it is the msx engine which is broken

Van Meits

Scribe (5481)

afbeelding van Meits

01-05-2012, 13:17

Seems like it's a regular occurring issue. Is this 8235 only or this MSX engine type?
Anyhow, your main board is total loss, unless if the settle for the keyboard (I wouldn't even notice if my joystick ports were broken Wink )

Van 800XL

Supporter (9)

afbeelding van 800XL

01-05-2012, 14:46

Okay, guys, I disassembled the thole thing this afternoon, but couldn't find anything.

Question 1: If it's really the MSX engine how could it be the rest of the machine works fine? This seems a very particular, singular fault.

Question 2: What's to be done about this? Are there peeps on this forum who can fix this sort of problem, in Germany at best? I would hate to see my new (well, for me anyway) MSX go to waste. Crying

Van Jipe

Paragon (1366)

afbeelding van Jipe

01-05-2012, 15:13

you can see a picture of MSX engine S3527 , change is not easy , search a new 8235 is a solution Wink

http://upload.wikimedia.org/wikipedia/commons/a/ab/S3527_01.jpg

Pagina 1/2
| 2