Can't boot msx dos

Door LeoSantos

Supporter (7)

afbeelding van LeoSantos

18-02-2014, 08:50

Hi,

I can't figure out how to boot from a disk containing msxdos2.sys and command2.com. It always goes straight to basic or to the Sony HitBit menu (I chose the same machine that I own, an old Sony HB-F1). The floppy is connected to the disk image and I can see the files, I just can't boot in msx dos.

I believe I have the required roms ( hbd-f1 for the floppy disk and hb-f1 for the machine ).

Am I missing something?
Thanks!

Aangemeld of registreer om reacties te plaatsen

Van Guillian

Prophet (3455)

afbeelding van Guillian

18-02-2014, 09:09

For loading MSX-DOS2 you need the DOS2 kernel (MSXDOS2.ROM).
It does not work with only the files as MSX-DOS does.

Van LeoSantos

Supporter (7)

afbeelding van LeoSantos

18-02-2014, 10:08

Yes, I have msxdos2.rom in the systemroms folder, but still can't boot in msx dos. Do I have to attach some extension to allow it to be used as well?

Thanks.

Van mars2000you

Enlighted (6014)

afbeelding van mars2000you

18-02-2014, 10:28

You need to select the msxdos2 extension in Catapult.

Van LeoSantos

Supporter (7)

afbeelding van LeoSantos

18-02-2014, 10:35

When I bring the console and type "list_extensions", I get:
msxdos2
Sony_HBD-F1

I tried booting a msx dos 1 disk and it seemed fine, I only have the issue with msx dos 2.
I'm trying to run TriloTracker, which comes in a.dsk with msxdos 2.

Thanks!
Leo.

Van mars2000you

Enlighted (6014)

afbeelding van mars2000you

18-02-2014, 10:57

The Sony HB-F1 has only 64 Kb RAM, you need at least 128 kB RAM to run MSX-DOS2.

Add more RAM in the extensions or replace the msxdos2 extension by the ASCII MSX-DOS2 extension (the Japanese ROM comes with extra RAM).

Van Huey

Prophet (2675)

afbeelding van Huey

18-02-2014, 11:09

LeoSantos wrote:

I'm trying to run TriloTracker, which comes in a.dsk with msxdos 2.

If you are using emulation, better use a turbo-R. It will work a lot better on R800 speed.
You can set the keyboard emulation back to international in the config menu (SHIFT+F5 in TT).

Van LeoSantos

Supporter (7)

afbeelding van LeoSantos

18-02-2014, 19:19

A-ha! I'll try it when I get home tonight, but that sounds about right.
Thanks!

Van LeoSantos

Supporter (7)

afbeelding van LeoSantos

19-02-2014, 07:05

Using a Turbo R worked great, thanks for the help!

Leo.