GOTEK on 8245

Door bear77

Rookie (24)

afbeelding van bear77

19-11-2018, 14:53

Hey guys, i have a problem with the GOTEK drive. Flashed the drive initially with v0.11 firmware.
Next i prepared a usb drive 2gb. Drive reconizes the .dsk images. The files in the dsk image can be loaded, no problems here. But when i change the images, it writes to the GOTEK (image.cfg) and frome there i cant get the disk to read again. The msx says "disk offline"
I tried different firmwares, different usb sticks(1gb, 2gb all fat32 formatted). My msx is a 8245. Original drive works perfectly.
Now i'm kinda stuck with it. Anyone any ideas?

Aangemeld of registreer om reacties te plaatsen

Van Bastion Rebel

Resident (59)

afbeelding van Bastion Rebel

19-11-2018, 17:23

hello
are you modified host=msx in ff.cfg ???

Van bear77

Rookie (24)

afbeelding van bear77

20-11-2018, 09:58

Yes, i have. Just like i said, when it writes "image.cfg" (last used image) the fun is over.

Van bear77

Rookie (24)

afbeelding van bear77

21-11-2018, 14:09

Anyone got other suggestions?

Van Alexey

Guardian (2899)

afbeelding van Alexey

22-11-2018, 00:36

What is your Gotek's jumper configuration? Also try downgrading the firmware and see if that solves the problem.

Van Fabf

Master (247)

afbeelding van Fabf

22-11-2018, 12:09

You can't use PC drive (or Gotek) directly on a NMS8245.
You need to modify ribbon as explained here : http://msx.hansotten.com/uploads/ffiles/Vervangen%20diskdriv...

Van Robby

Master (194)

afbeelding van Robby

22-11-2018, 17:56

Van bear77

Rookie (24)

afbeelding van bear77

23-11-2018, 07:13

Thanjs for the reply, but all of that is good. ICAN get the directory to see. The problem occurs when i start loading a file or write to the GOTEK. Tried both jumpersettings jc open and jc closed. Default drive 0

Van Philip

Champion (373)

afbeelding van Philip

23-11-2018, 10:16

So you did modify the cable as explained in the pdf Fabf posted?
Perhaps you can doublecheck the connections of the cable. It could be the side select is not working.

Van bear77

Rookie (24)

afbeelding van bear77

23-11-2018, 11:36

I have an adapter made by Omega, and a modified flatcable. Both the same results