Debugger can't find active sessions

Pagina 1/2
| 2

Door warmize

Resident (48)

afbeelding van warmize

07-01-2020, 02:02

Hi,

I can't debug with OpenMSX debugger because it can't find active sessions. For some weeks It has been a problem as debugger could not connect with openMSX 100% of times but the last days it hasn't worked at all.

I have tried all the stuff found in these forums (maybe I missed something?). I deleted all temporary data in my profile but nothing happens. Does anyone has a list of temporary files to delete? Is there anything that I am missing?

I'm using 0.10.0-268 version of the debugger and OpenMSX version 0.15.0 for Windows.

Thank yoU!

Aangemeld of registreer om reacties te plaatsen

Van Manuel

Ascended (16702)

afbeelding van Manuel

08-01-2020, 00:09

Hi, as I asked here: https://www.msx.org/forum/msx-talk/general-discussion/help-o...

Did you find any files on these temp file locations?

Van warmize

Resident (48)

afbeelding van warmize

14-01-2020, 14:33

Yes I did. Let me check it again and I'll post them here before I delete them.

Van PingPong

Prophet (3530)

afbeelding van PingPong

14-01-2020, 20:36

I've got the same problem on my windows 7 machine. i was not able to find the cause. Manuel told me about a specfic feature used on windows so to solve the problem, i've fired up a vmware linux mint machine. It worked, but for a while. Apparently without any reasonable cause the same problem showed up even under linux.

Tired of the situation, i've deleted the linux machine and got back to the windows one with the intention to know what does go wrong. So launched openmsx via catapult and the the debugger. And to my surprise the things returned to work as expected.
As today i really do not know what the issue is caused by.

things verified:

the debugger correctly locate the file
the debugger correctly read in the port number used to start the connection (if i remember was 9990)
the port is open and there is no firewall stopping the connection
the connection would not open from the openmsx debugger process
a simple telnet localhost portnumber open the connection with openmsx

Van akumajo

Resident (43)

afbeelding van akumajo

15-01-2020, 08:02

Not sure it can help, but my situtation is as follow :
I use linux Ubuntu at home and Windows 7 (enterprise) ar work.
On linux I've never had any connection problem between openmsx and debugger. On Linux the debugger (or openmsx?) create a temp file holding the process id of the connection, unlike Windows which create a TCP connection with an assigned port.

On Windows, if you execute the command "netstat -an > nstat1.txt" before establishing connection and "netstat -an > nstat2.txt" once connection estalished, you will get the TCP lines connection with port number.
(by comparison between the two files)
For instance :
1) before connection :
TCP 127.0.0.1:58494 127.0.0.1:9962 TIME_WAIT (this is openmsx waiting)
2) during connection :
TCP 127.0.0.1:9962 127.0.0.1:58494 ESTABLISHED (debugger)
TCP 127.0.0.1:58494 127.0.0.1:9962 ESTABLISHED (openmsx)

A few months ago, I developped a program (C language then Java) to communicate with openmsx. On Ubuntu, no problem, but on Windows the connection has always been refused. I therefore wonder if Windows (depending on the version) allows TCP communication between applications only under certain authorization conditions Question

Van Manuel

Ascended (16702)

afbeelding van Manuel

15-01-2020, 10:35

For security reasons, you have to use SSPI negotiation on Windows. As far as I understand, this makes sure that only the user that runs openMSX can connect with the debugger to openMSX. On UNIX/Linux this is arranged by a UNIX Domain Socket. Those provide the same security: only the same user may connect.

Van Ritcher1986

Master (151)

afbeelding van Ritcher1986

21-01-2020, 21:47

Sorry for my English, I'm using a translator. I also have problems with the debugguer, I leave you an image with the error you are giving me. I am using the latest stable version of openmsx and python 3.x. Greetings.

error openmsx

Van Manuel

Ascended (16702)

afbeelding van Manuel

21-01-2020, 21:55

Ritcher: that message only seems to be a warning... What is the problem with the debugger?

Van Ritcher1986

Master (151)

afbeelding van Ritcher1986

22-01-2020, 08:37

The problem is that no active session appears to connect me

error openmsx debug

Van Manuel

Ascended (16702)

afbeelding van Manuel

22-01-2020, 09:22

I don't see openMSX running in that screenshot... is it running?

Van Ritcher1986

Master (151)

afbeelding van Ritcher1986

23-01-2020, 01:30

Hi Manuel, in this picture I hope you see it better. Greetings!
error openmsx debug

Pagina 1/2
| 2