HB-F1XD DiskBIOS BUG

Pagina 1/2
| 2

Door hirotyan

Supporter (7)

afbeelding van hirotyan

20-06-2021, 06:27

This is a bug report.

When using the HB-F1XD Disk BIOS with openMSX, the screen looks strange.

There is no problem when using the FS-A1GT BIOS.

I'm not in particular trouble. Because there is a BIOS that works correctly.

I always enjoy using openMSX. I am grateful to everyone involved.

Aangemeld of registreer om reacties te plaatsen

Van Pencioner

Scribe (1468)

afbeelding van Pencioner

20-06-2021, 10:20

If you could post an XML with this exact slot configuration you're using, it would be easier to developers to understand and fix the problem. Thanks!

Van hirotyan

Supporter (7)

afbeelding van hirotyan

20-06-2021, 14:04

I'm using a Catapult and just selecting "Sony HB-F1XD" as the MSX type.
Other than that, it is the default setting.
If you need an XML, I will post it here, so please tell me the file name.(settings.xml ?)

Van Pencioner

Scribe (1468)

afbeelding van Pencioner

20-06-2021, 15:13

I'm not speaking for myself (i'm not in openMSX team), i just noted that in the first post the information was too generic (in my opinion) Smile

Van hirotyan

Supporter (7)

afbeelding van hirotyan

20-06-2021, 16:56

sorry. Thank you for teaching me!
Perhaps regardless of the settings, selecting the HB-F1XD BIOS will always result in a strange display.
This game is "LAST ARMAGEDDON". I also confirmed "Tír na nÓg" too.

Van Grauw

Ascended (10022)

afbeelding van Grauw

20-06-2021, 16:57

Did you dump the BIOS yourself or did you get the one from “the archive”?

Van hirotyan

Supporter (7)

afbeelding van hirotyan

20-06-2021, 17:45

I got archive one.
hb-f1xd_disk.rom
sha1:12f2cc79b3d09723840bae774be48c0d721ec1c6

Van Manuel

Ascended (18092)

afbeelding van Manuel

20-06-2021, 19:47

How can I test this myself? I can't read Japanese, so I don't know how you get to see the problematic screen.

Van sdsnatcher73

Prophet (2153)

afbeelding van sdsnatcher73

20-06-2021, 20:25

Boot from disk 2, when prompted insert disk 3 (or C). Choose the second entry in the menu. For me it loads fine on HB-F1XD in openMSX 17.0-8 build but not in 17.0 release build.

Van Manuel

Ascended (18092)

afbeelding van Manuel

20-06-2021, 21:07

I get the menu back when I choose the second entry....

EDIT: ah, you need to press ENTER, not SPACE....

Van Manuel

Ascended (18092)

afbeelding van Manuel

20-06-2021, 21:36

OK, looks like this bug got fixed almost RIGHT after the 17.0 release: https://github.com/openMSX/openMSX/commit/ba933dd3ce131775eb...

So, thanks for reporting, but it is already fixed... if you want to use it, just get the latest development build from http://openmsx.dev/ or wait for the next release to happen (may take months).

Pagina 1/2
| 2