Problema con LPE-MMC-V7 en VG8020 no funciona

Page 2/4
1 | | 3 | 4

By KiD

Supporter (6)

KiD's picture

15-02-2011, 12:50

Hola, yo tengo un Philips VG8020 con la tarjeta LPE-MMC-V7, y va perfectamente.
Lo primero decirte que es un MSX1 con lo cual las tarjetas sólo podrás formatearlas en FAT12, ver Nota en el manual:

"Con el formateo DOS1, todas las particiones realizadas en la tarjeta serán de 16
Megas FAT12. Este tipo de particiones son totalmente compatibles con la versión
1.0 de MSX-DOS y Disk Basic, pudiendo trabajar con ellas como si de un disco
flexible se tratase.

No es posible realizar particiones de mayor tamaño en MSX-DOS versión 1.0."

Si utilizas una tarjeta de 1Gb echa cuentas la cantidad de particiones que tendrás en 1Gb/16Mb = 64 particiones, asi que igual es mejor que utilices una tarjeta menor, incluso no sé si se podrá formatear una tarjeta de 1Gb con FAT12, yo utilizo de 256Mb y 512Mb y van bien.

Luego una vez echo el formateo, ya puedes arrancar el sistema operativo, otra nota del manual:

"Una vez formateada la tarjeta a gusto del usuario ya podemos arrancar el sistema
operativo. Para ello solo hemos de copiar a la primera partición los ficheros
MSXDOS.SYS y COMMAND.COM (si disponemos de al menos 64k de Ram) o bien
MSXDOS2.SYS y COMMAND2.COM (si nuestra computadora dispone de 128k de Ram
mapeada o más).

En sistemas con menos de 64k de Ram no podremos utilizar el sistema operativo
MSXDOS, ni tampoco las utilidades externas para el sistema operativo.

Los ficheros pueden ser copiados bien desde el propio MSX si dispone de alguna
otra unidad de disco, bien desde otro sistema como Windows, Linux o Mac OSX. "

En el VG8020 sólo puedes copiar los ficheros: MSXDOS.SYS y COMMAND.COM, y lo más rápido sería copiarlos del PC a la tarjeta.

Ya me contarás si esto te ha servido de algo...

Saludos.

By Dreamerm42

Hero (621)

Dreamerm42's picture

15-02-2011, 14:48

He grabado un video siguiendo las indicaciones de KID y esto es lo que pasa siempre:

http://www.youtube.com/watch?v=SEmiavdJzVk

Ahora comento :P

Como puedes ver entro y formateo en fat12, crea las particiones que cree oportunas y sin DOS en el MSX2 VG8235 arranca el interprete de BASIC con el mensaje Disk BASIC version 2.01

Con DOS 1.0 carga perfecto y totalmente funcional.

La misma operacion en un MSX1, da como respuesta un continuo reseteo, una vez se sale de la utlidad interna, da igual contenga o no el DOS.

Si extraigo la tarjeta, el ordenador arranca detecta que no tiene tarjeta SD y aparece el interprete de BASIC sin el mensaje de Disk Basic ver 2.01.

Ahora me pregunto:

Si, ciertamente en el manual pone que hacen falta 64kb, entonces en ordenadores con menos ram no funcionaria, pero si la tarjeta tiene ya 4Mb no tendria que tener problemas, no?

A mi me llama la atencion que con la tarjeta SD puesta el ordenador se reseta continuamente, la quitas y arranca el basic...

¿sera consumo?
¿sera que el pobrecito esta viejo y la fuente no da mas de si?
¿sera que yo no soy capaz de hacerlo funcionar?

*_**_**_*:-?:-?*_**_*

By KiD

Supporter (6)

KiD's picture

15-02-2011, 16:44

Pon siempre el sistema operativo en la tarjeta por si quieres probar el arranque desde la tarjeta (MSXDOS.SYS y COMMAND.COM para MSX1).

Si arrancas el BASIC, entonces tienes que copiar los commandos del fichero http://msx.deneb.nl/DRSDMMC1.lzh en la primera partición, que son comandos para el manejo de las tarjetas.

Por otra parte creo recordar que yo al principio también intenté usar una tarjeta SD y creo que me hacía lo mismo que a tí; pero no estoy seguro porque ahora mismo no lo puedo probar. Al final terminé usando unas tarjetas MMC de unos teléfonos antiguos que tenía y me funciona sin problemas. Además veo en el vídeo que tu tarjeta es SD de 512Mb, pero es detectada con 445120512 bytes, que son más o menos 424Mb, con lo cual a mí me parece que la está detectando mal.

By Dreamerm42

Hero (621)

Dreamerm42's picture

15-02-2011, 16:50

Eso hice ya como tu comentaste, y la tarjeta del video es de 512 cierto, pero, es que he probado con 512,128 y 64megas, solo me queda probar con una tarjeta mmc de algun antiguo nokia, pero como el problema este hay, pufff donde encontramos ahora tarjetas mmc?

bueno a ver si encuentro la tarjeta y reviso.

gracias por el interes.

By KiD

Supporter (6)

KiD's picture

15-02-2011, 17:07

OK, ya contarás...

By Guseco

Expert (68)

Guseco's picture

16-02-2011, 08:54

Una aclaración yo dispongo de la LPE-MMC-V7BKP la tarjeta basica sin ram ni mapper. El resultado con una tarjeta SD de 1GB es el mismo que el tuyo Dreamerm42.

Muchas gracias a todos por aportar vuestros comentarios.

Guseco LOL!

By pitpan

Prophet (3131)

pitpan's picture

16-02-2011, 09:20

En el VG8020, para hacer funcionar la ampliación de memoria de Padial de 4MB SIN adaptador de tarjetas SD (que es mi configuración) lo que hago es lo siguiente:

- Encender el ordenador con la ampliación conectada
- Desde el MSX-BASIC teclear lo siguiente:

OUT (#FF),0
OUT (#FE),1
OUT (#FD),2
OUT (#FC),3

- Hacer un reset

A partir de ese momento, mi VG8020 me reconoce los 4MB correctamente. El código anterior lo que hace es ajustar "a mano" los registros del mapper. Gracias a eso puedo utilizar después mi IDE-CF con MSX-DOS2, que ya sabéis que necesita de mapper y al menos 128 KB de RAM para funcionar adecuadamente.

Comentadme si ha habido suerte con este procedimiento, porque igual sí que me pillo el interfaz SD de Padial para usarlo desde mi MSX. Con las CF estoy bien, pero luego me dan problemas para compartir datos con el PC.

By x-nen Aivalahostia

Paragon (1030)

x-nen Aivalahostia's picture

16-02-2011, 09:37

Hola a todos de nuevo, yo tengo la tarjeta LPE-MMC-V7 la que lleva el mapper incorporado, y tengo un vg8020 y un hitbit 75p, en el vg8020 no he conseguido hacerlo funcionar en cambio en el hitbit no hay ningun problema.
En su momento prove de particionar en fat 12 intalar el msxdos no el msxdos2.... sin conseguir resultados satisfactorios.
En su momento Padial me puso en contacto con un usuario (perdon por no acordarme del nobre de este) que disponia del Vg8020 y que a el si que le funcionava, Pero el tenia el papper y el lector en diferente cartucho.
Personalmente creo que es un problema propio del diseño de los VG8020, y no de la placa de Padial, si os acordais habia toda una serie de juegos que no cargaban en este y si en el resto de los msx (double dragon, wec le mans, ....)
Tambien tenemos que tener en cuenta que hay diferentes modelos de VG8020, yo tengo el VG8020/20 y segun me parec e recordar hay el /00, /19 y /40 entre todos ellos hay pequeñas diferencias a nivel de circuitos internos, por lo que podria ser que que en los /20 no funcionara de ninguna de las maneras y en los /00 /19 o /40 funcionara bien o parcilamente.
De momento este finde voy a probar siguiendo las intrucciones de Kid y ya os comentare.

Saludos a todos!!

By Guseco

Expert (68)

Guseco's picture

16-02-2011, 10:56

Yo tambien tengo un VG8020/20 pero la tarjeta es la básica sin 4MB la LPE-MMC-V7BKP. No funciona con memorias SD.

Una pregunta para ti KiD. ¿Que modelo de VG8020 tienes? ¿Es es VG8020/20 tambien?

Muchas gracias de antemano,

Guseco Cool

By KiD

Supporter (6)

KiD's picture

16-02-2011, 11:18

Pues ahora mismo no lo sé, y hasta dentro de un par de semanas no voy a estar donde tengo el MSX. Pero yo creo que el tema viene porque las tarjetas SD no les va bien el formateo en fat12, por eso sí funcionan en MSX2 formateadas en fat16 (esto lo podría confirmar otra persona con un MSX1 distinto del VG8020 a ver si le funciona una SD con fat12).
Yo también poseo la LPE-MMC-V7BKP (sin los 4MB de memoria), asi que lo que yo probaría con tarjetas SD sería lo siguiente: sin ninguna tarjeta introducida en el slot probar lo que dice el usuario pitpan y habilitar los 4MB de memoria, una vez hecho esto probar a formatear la SD con fat16, y en la primera partición poner los ficheros del MSX-DOS2 y rezar a ver si funciona, si no probar con una tarjeta MMC para ver si al menos funciona algo.

Saludos, y en cuanto pueda te digo el modelo del VG8020.

Page 2/4
1 | | 3 | 4