MegaFlashROM SCC+ SD

Page 74/115
67 | 68 | 69 | 70 | 71 | 72 | 73 | | 75 | 76 | 77 | 78 | 79

By Imper4tor

Supporter (9)

Imper4tor's picture

12-04-2016, 16:42

Hola

Me a pasado algo muy raro, tenía arrancado MultiMente (MM) y me disponia a salir a basic para particionar y formatear una nueva tarjeta sd.
En ese momento se a quedado todo bloqueado. Al arrancar de nuevo se queda bloqueado antes de arrancar multimente con un simbolo extraño debajo del texto que indica SDHC detectado. He usado tecla arriba y recovery F1+F2+F3 Y F4 reinstalado kernel.dat.
Al intentar arrancar ahora ya no sale el simbolo extraño pero se queda en la pantalla de inicio con el texto que indica SDHC detectado sin posiblidad de usar teclado ni nada. ¿Ha muerto definitivamente? Evil
¿pueden ser los contactos?

Tengo un Phillips 8235

de aqui no pasa

By Guillian

Prophet (3294)

Guillian's picture

12-04-2016, 17:08

Prueba a limpiar los contactos del cartucho y del slot del ordenador.
Si tienes otro MSX a mano, prueba el cartucho en él, para descartar algún problema en el 8235 (p.e.: en la fuente de alimentación cuando lleva un rato funcionando)

By Imper4tor

Supporter (9)

Imper4tor's picture

12-04-2016, 17:30

Lo otros msx que tengo son MSX1 de 64 kb como máximo, ¿carga Multimente en Msx1?

By Guillian

Prophet (3294)

Guillian's picture

12-04-2016, 17:57

No, pero arrancará el MSX-DOS

By Imper4tor

Supporter (9)

Imper4tor's picture

12-04-2016, 23:07

PERFECTO!!! Con el msx1 cargo los juegos de versión msx2, luego cambio el cartucho al msx2 y funciona perfecto.
Lo que funciona mal es el acceso a A: o al kernel en el msx2, porque una vez cargado el rom funciona perfecto, al igual que el modo recovery.
¿Alguna idea de como podría solucionarse?

By Guillian

Prophet (3294)

Guillian's picture

13-04-2016, 10:14

Prueba a volver a reinstalar el KERNEL.DAT desde recovery, pero asegúrate de que la tarjeta está totalmente vacía o formateada antes de copiar el fichero en ella.

By Imper4tor

Supporter (9)

Imper4tor's picture

14-04-2016, 16:09

Nada Sad todo reinstalado y se comporta igual , al parecer debe ser un problema de hardware, puesto que al principio de arrancar el Phillips 8235 Nestor y Multimente funcionan perfectos, cuando llevo 5 minutos aunque reinicie y apague totalmente ya no consigo hacerlo funcionar. Sin embargo las roms cargadas en el cartucho y recovery funcionan perfectos. XXC

Igualmente Muchas gracias por tus respuestas!!

By Guillian

Prophet (3294)

Guillian's picture

14-04-2016, 16:53

A priori parece que el cartucho funciona bien. El "chip" donde está el recovery, las ROMs cargadas y Nextor es el mismo.
Así a bote pronto se me ocurre que pueda fallar la memoria del 8235 al calentarse, por eso Nextor no te carga.
Cuando te falle, prueba a arrancar pulsado el 1. De esta forma arrancará en modo MSX-DOS1 y solo usará los primeros 64K de RAM del ordenador. Si te arranca (el MM no funcionará porque necesita MSX-DOS2) el problema podría estar en los 64K altos de la RAM.

En ese caso los juegos en ROM te funcionan sin problema porque suelen usar solo 16K de RAM.

By Imper4tor

Supporter (9)

Imper4tor's picture

15-04-2016, 22:02

Hola Guillian
He hecho la prueba que indicas varias veces. Al principio pensé que habias dado en el clavo, pero al rato continuó dejando congelado el arranque pese a intentar ir al msx-dox manteniendo pulsado 1.
Muchas gracias por tu ayuda igualmente y permíteme darte a conocer el evento para gente del mundillo retro y retroprogramadores que organizamos en mi asociación al que nos encantaría que asistieses si tienes oportunidad.

http://arcadevintageshop.blogspot.com.es
Si estás interesado en asistir o te gustaría ir como ponente en este año o el próximo podríamos intentar coordinarlo.

By Guillian

Prophet (3294)

Guillian's picture

16-04-2016, 09:36

Otra prueba que se me ocurre cuando te falle es que pulses R (si tienes el cartucho en el slot 1) o F (si está en el 2). Así evitas que cargue Nextor o el MSX-DOS1 y arranque en BASIC.
Una vez en BASIC (si es que arranca) podrías intentar ver si realmente se trata de un problema de memoria. Por ejemplo viendo si tras escribir un programa en BASIC se corrompe. O escribiendo datos con POKE en un área de la memoria y luego comprobando si esos datos siguen ahí correctamente.
También puedes probar a cargar desde disco el MSX-DOS y ver si se cuelga o no.

Gracias por la invitación y la información. El 30 de abril estaré por Valencia. Me han invitado los organizadores de Retropolis para ir a dar una charla sobre La abadía del crimen extensum.

Page 74/115
67 | 68 | 69 | 70 | 71 | 72 | 73 | | 75 | 76 | 77 | 78 | 79