Problema con joystick en nms8245

Page 1/3
| 2 | 3

By inspecteurZ

Rookie (31)

inspecteurZ's picture

02-02-2015, 22:55

Hola a todos.
Tengo un problema que por lo que he leído es más común de lo que pensaba, aunque no me ha quedado claro como solucionarlo. El puerto 1 del joystick parece como si tuviera siempre el disparo pulsado, incluso si no hay joystick conectado. El puerto 2 parece ir bien, aunque según que juegos interfiere con el otro y no se puede usar.

He revisado soldaduras y están bien, por lo que me temo que sea culpa del S3527. ¿Hay alguna otra cosa que pueda probar para identificar el problema? Si es cosa del S3527, ¿se pueden conseguir recambios y es posible soldarlo a mano?

Gracias y un saludo.

Login or register to post comments

By jrcp_kun

Paragon (1410)

jrcp_kun's picture

03-02-2015, 17:39

en basic puedes hacer un programilla que te diga si siempre esta pulsado. y si . suele ser ese componente que se queda en cortocircuito

By e_sedes

Expert (112)

e_sedes's picture

03-02-2015, 18:50

Si es el disparo 1 (o A, o como le llames) puede ser un transistor que va en ese pin. Eso puede ser más fácil de solucionar, si es eso.

By inspecteurZ

Rookie (31)

inspecteurZ's picture

03-02-2015, 22:40

Gracias a los dos por contestar.

He hecho las pruebas en basic con stick y strig, pero el problema parece estar con el segundo botón (no se como probar ese botón en basic).

Probando varios joystick con Salamander a 2 players, esto es lo que he sacado en claro:

- En el puerto 2 todos los joysticks funcionan como se espera.
- En el puerto 1 todo funciona menos el botón 2, que depende del joystick:
+ Con teclado (sin joystick conectado) el botón 2 (M o N) no hacen nada. Por supuesto esas teclas funcionan en BASIC.
+ Con un pad Joycard SuperII de Hudson, el botón 2 no hace nada. Pero si activo el turbo, entonces si lo coge.
+ Con un Yanjen parece que funciona bien (aunque he tenido la sensación de que a veces queda la pulsación del botón "en espera" y salta más tarde, pero puede que sea por el tipo de joystick)
+ Con un Sanyo MJY-002 el disparo 1 parece estar en automático (dispara sin pulsarlo) y el 2 no hace nada. De este no me fío, porque internamente parece tener cruzados los dos disparos, y en el puerto 2 solo funciona el primer botón (aunque no automáticamente)

Pues esas son las pruebas que he hecho. Si alguien tiene alguna idea se lo agradecería. También si alguien sabe como probar el botón 2 en basic.

Por cierto @e_sedes, ¿los transistores son unos trastos azules que pone 271 TDK? porque no se parecen a los transistores de toda la vida, aunque tienen 3 patas.

By ENDDEMOGAMITAINA

Paragon (1276)

ENDDEMOGAMITAINA's picture

03-02-2015, 23:08

Para mi que es la clasica averia,tendras que cambiar el Integrado que se cortocircuito...,
intenta esto,
mira el PIN que te falla...mirando un PINOUT MSX JOYSTICK,
luego sigue su pista...a ver donde te lleva la madrigera de conejo.
es una averia super comun y sobre todo me sucedio en muchas placas JAMMA,
en este foro tiene que algun forero saber exactamente que integrados son los que controlan eso en los MSX,
por ejemplo si son 74LS244 tipicos que se utilizaban tanto para esas cosas, o quizas en MSX son otros...,
pero no andara lejos del puerto el villano.
a ver si hay suerte.
saludos.

By e_sedes

Expert (112)

e_sedes's picture

03-02-2015, 23:31

Para mirar el disparo 2 del joystick 1 usa strig(3). Para el disp.2 del joy.2 es strig(4).
Ese comportamiento errático según el joystick que le enchufes me tiene pinta de alguna soldadura mala, que hace contacto según le parezca. Busca el mando más sencillo que puedas, sin turbos ni nada y prueba con ese.
El transistor que te decía no se que pinta tendrá, pero supongo que normal. No tengo un 8245. Échale un ojo al manual de servicio.

By inspecteurZ

Rookie (31)

inspecteurZ's picture

04-02-2015, 00:48

Gracias. Mañana hago alguna prueba más.
Un saludo.

By osises

Master (214)

osises's picture

04-02-2015, 17:48

Hola:

No se si será el caso, pero lo cuento por si acaso.

Curiosamente esto me ocurrió con la bandeja de papel de una impresora de gran formato, que tenía un conector cuadrado con varios pines. Pues bien, un trocito de papel se coló dentro del conector hembra y el macho, que estaba en la bandeja, no hacía contacto, por lo que causaba un mensaje en el display que indicaba bandeja abierta y se quedaba cuajada.

En este caso podría ser que un cuerpo extraño (como dicen los médicos) esté metido dentro del conector y haga un falso contacto. Compruébalo. Imagino que igualmente podría haberse producido el "corto" en alguna pista o componente de la placa, habría que verificar también eso.

Por supuesto imagino que la causa más probable sea algún componente que esté entre el engine y el puerto físico. Ojalá sea uno común que puedas conseguir facilmente y te permita repararlo.

El problema común que he observado en los Philips MSX2 como este, es que los pines de los joystick se ensucian mucho por óxido (un aspecto mate y roñoso los delata). Un buén repaso para limpiarlos y solucionado. Pero no creo que sea el problema que tienes.

Espero que lo puedas reparar facilmente, ya que es uno de los MSX2 que, personalmente, creo que funcionan bastante bién.

Saludos,

Oscar

By inspecteurZ

Rookie (31)

inspecteurZ's picture

04-02-2015, 22:11

Bueno, pues parece que va a ser el s3527. He comprobado desde basic que el botón 2 del puerto 1 está siempre activo (-1). Con ayuda del manual de servicio he seguido pistas y lo único entre el puerto y el controlador es el componente azul de 3 patas que comentaba en el otro post, y que según el manual son dos bobinas con un condensador conectado a masa. Para asegurarme que el componente estaba bien, lo he intercambiado con el mismo del puerto 2, y sigue fallando igualmente el puerto 1, con lo que el fallo está en el s3527 (también he comprobado como decía osises que el puerto estaba limpio y libre de oxido).

Así pues, ¿alguien sabe donde conseguir un s3527 y donde me lo podrían instalar? Es muy pequeño y son muchas patas como para atreverme yo a meter mano.

Gracias y un saludo.

By jrcp_kun

Paragon (1410)

jrcp_kun's picture

04-02-2015, 22:58

de donde eres ??

By inspecteurZ

Rookie (31)

inspecteurZ's picture

04-02-2015, 23:56

De Barcelona

Page 1/3
| 2 | 3