Ayuda con MSX2 PHilips NMS 8280.

Page 3/3
1 | 2 |

By Hokuspokus

Expert (76)

Hokuspokus's picture

24-12-2018, 17:53

El caso es que "medio arranca", pero no muestra nada en pantalla...puede ser que la vram este dañada y por eso no muestra nada y se bloquea o incluso que la ram este defectuosa y no consiga copiar/arrancar la rom basic/extension/floppy en la ram...Nose si tirarme a la piscina y comprar unos zocalos y chips de memoria ram/vram que son los mismos y hacer un "change". Si eso no funcionara cambiaria todos los chips logicos 74lsXXX que tenga algo que ver con el acceso a memoria. En el manual de service se pueden ver bien cuales son.

P.d.: Antes deberia mirar si a la cpu/vdp/ram/vram le llega alimentacion. La ultima opcion seria cambiar la CPU Z80!.

By mohai

Paladin (761)

mohai's picture

10-01-2019, 15:30

Hokuspokus wrote:

Sospecho que la placa de video debe estar mal o alguna rom del sistema en la placa madre. El caso es que lo enciendo, el teclado me funciona, se puede poner y quitar las mayusculas y hace testeo de la disquettera. Pero no sale nada en pantalla ni siquiera la Tv detecta señal de video...

Hola,
por lo que dices, en tu MSX están funcionando bien bastantes cosas: El Z80, las ROMS (yo diría que todas, incluida la de BASIC), el VDP (al menos, genera interrupciones) y la RAM.
Yo me incliniaría más a que es un fallo en la circuitería de vídeo o la VRAM.

Supongo que ya has probado las diferentes salidas de vídeo: SCART, vídeo compuesto, etc.

¿Has probado a poner el comando FILES (enter) desde BASIC y mirar a ver si la disketera intenta leer de disco?

By hardwaremaker

Master (213)

hardwaremaker's picture

10-01-2019, 18:16

En los MSX, un fallo en la RAM, genera una pantalla en negro. No necesariamente tiene por que ser un fallo en la VRAM.

By Hokuspokus

Expert (76)

Hokuspokus's picture

11-01-2019, 16:43

He pedido chips de memoria nueva 41464, zocalos y algun chip logico tipo 74LS157 para cambiar la ram y la vram. Gracias por las aportaciones colegas!.

By Hokuspokus

Expert (76)

Hokuspokus's picture

11-01-2019, 19:03

Hace el testeo de la disquettera, pero si pones un disquette con un juego autoejecutable, no llega a ejecutarse porque no vuelve a leer de la disquettera. Con esto creo que no llega a "prompt" del sistema basic...podria ser la bios del basic, pero no creo porque antes ya deberia emitir señal de video. A ver si se os ocurre algo que mirar. Saludos!.

By Pablibiris

Paragon (1722)

Pablibiris's picture

12-01-2019, 03:19

yo iria directo a la RAM

By Hokuspokus

Expert (76)

Hokuspokus's picture

14-01-2019, 16:44

Hoy he estado probandolo a fondo y parece que todo esta bien, se enciende y hace el testeo de las disquetteras y tambien vuelve a leer de la disquettera. Responde bien al comando "FILES", lee de la disquttera, el fallo esta en que la imagen sale desincronizada y casi no se ve nada en la pantalla, sale asi corrido hacia un lado pero muy aplastado y rapido!. Osea el fallo esta en la placa analogica de video!. A ver si alguien me puede decir que mirar o que cambiar.

P.d.: El frontal no lo tengo del ordenador y por lo tanto nose si delante tiene algun boton para sincronizar o algo... he detectado el cable del reset y el de la luz power, pero ademas tiene una par de cables anchos y dos mas de 3 pines.

By Hokuspokus

Expert (76)

Hokuspokus's picture

14-01-2019, 23:23

Ya esta todo arreglado y funcionando.Gracias por la ayuda!

By hardwaremaker

Master (213)

hardwaremaker's picture

15-01-2019, 00:54

¿Cual era el problema finalmente?

By Hokuspokus

Expert (76)

Hokuspokus's picture

15-01-2019, 17:48

Simplemente puentear un cable de 3 hilos que va hacia el frontal... porque el frontal del ordenador no lo tengo, no lo tenia el que me lo vendio. Saludos.

Page 3/3
1 | 2 |
My MSX profile