Pantalla en blanco al intentar deshabilitar Menu de inicio en HB-101p

Page 1/2
| 2

By Franz72

Supporter (8)

Franz72's picture

20-05-2020, 20:39

Hola a todos, acabo de adquirir, recientemente, un MSX HB-101p y he intentado saltar el menu de inicio que tiene usando las combinaciones de teclas: CTRL-SHIFT-CODE-GRAPH, pero me sale una pantalla en blanco con lo que no puede cargar el cartucho Nextor SD Mapper Megaram. La pantalla en blanco sale cuando no está el cartucho y se queda en azul cuando está puesto. Os agradecería cualquier indicación al respecto. Saludos!

Login or register to post comments

By Josevil

Master (178)

Josevil's picture

20-05-2020, 23:14

antes de nada comentar ,que entiendo que con lo que comentas no inicia el basic indiferentemente de que este o no puesto el cartucho nextor sd (La pantalla en blanco sale cuando no está el cartucho)

si es eso a lo que te refieres intenta iniciar con un cartucho de un juego para saltar el filware si no funciona tampoco puede que lo que tengas es alguna eprom mal y mas cosas vinculadas (74ls)

si lo que te refieres es a una cosa puntual con el sd maper ,no puedo ayudarte ,un carnibore 2 es capaz de funcionar con ese filware en un hb-101p

By Franz72

Supporter (8)

Franz72's picture

20-05-2020, 23:49

Tenga o no puesto el cartucho (Nextor SD) la pantalla se queda en blanco. Lo he probado en un Msx2 HB-F9S, que para saltar el menú de inicio es con la tecla graph, y funciona sin problema con el cartucho puesto y sin él.
De momento, no dispongo de ningún cartucho de juego para probar lo que me comentas pero entiendo que aclararía bastante la situación.

By hardwaremaker

Master (238)

hardwaremaker's picture

21-05-2020, 07:22

¿Qué ocurre si simplemente, seleccionas la opción "BASIC" del menú?

By Josevil

Master (178)

Josevil's picture

21-05-2020, 10:12

lo que tienes es un msx1 que no funciona indiferentemente de lo que comentas ,puede que sea una eprom o un 74ls ,lo que te comente intenta arrancar con un juego en cartucho original si arranca será la eprom del filware corrupto o un 74ls en este caso si tienes conocimientos de electrónica y herramientas para poder quitar los elementos dañados adelante son placas bases muy delicadas ,lo malo que sea un 74ls dañado ,esa placa tiene demasiados .

funcionando en wallapod se suelen vender por 30 a 40 indiferentemente de que la gente los anuncie por mas dinero ,ten encuenta ,que es un modelo nacional que suele acabar en la basura aun que funcione bien ,la gente no suele perder el tiempo en anunciar algo que solo saque 20 o 30e .
si eres un entendido de electrónica y tienes tiempo adelante ,si no compraría una unidad estética que estuviera muy mal y repararía la tuya .

como consejo si te gusta este mundillo compraría un msx2 nacional funcionando suelen andar por 100 o 150e y se puede forzar el arranque a 60hz cosa que en msx1 no se puede .

By Franz72

Supporter (8)

Franz72's picture

21-05-2020, 18:03

La opción "BASIC" aparece sin problema y funciona correctamente.
Al pasar a BASIC con el Cartucho Nextor puesto, antes de iniciar la pantalla habitual de msx, me pide poner la fecha.
No tengo mucha idea de electrónica por lo que no me atrevería a ir modificando cosas de la placa.
Sería más fácil el cambiarle la eprom donde está instalado el firmware que un 74ls, ¿no?, Pero si, en principio,el sistema operativo funciona correctamente no podría ser algo que tenga que ver con el modo de 'screen 0', que tampoco se muy bien qué es!

By Josevil

Master (178)

Josevil's picture

21-05-2020, 19:34

vamos por partes

quita el cartucho basicnextor con sd de las pruebas tiene su propio basic que sustituye el interno

1 el ordenador arranca el filware?
2 el ordenador carga basic msx1 ?

si 1 y 2 es que si ,no pasa nada solo que tienes una incompatibilidad con el sd cuando lo usas (lo mejor es siempre un msx sin filware )

si 1 y 2 es alguna que no lo que te comente anteriormente.

By Franz72

Supporter (8)

Franz72's picture

21-05-2020, 20:08

1 el ordenador arranca el filware?
Si
2 el ordenador carga basic msx1 ?
Si
Cuando hablas de filware te refieres al firmware que vienen con estos modelos en concreto, ¿verdad?
Buen cuestionario, pero la cuestión está en que, tenga puesto o no el cartucho Nextor, al combinar
las teclas:CTRL-SHIFT-CODE-GRAPH se queda la pantalla en blanco, aunque las teclas se oyen al pulsarlas.
Por eso preguntaba lo de 'screen 0'

By Josevil

Master (178)

Josevil's picture

21-05-2020, 21:24

escribe screen 0 y pulsa intro

luego puedes probar con color 14,1,1 y intro

y comentas

la solución buena puéde ser eliminar ese filware

By snakepow

Champion (294)

snakepow's picture

22-05-2020, 10:18

Prueba de hacer lo siguiente:

Entra al Basic, seleccionando la correspondiente opción del programa "firmware"

Una vez estes en Basic, teclea:

call system (seguido de tecla Return)

Ya me dices si te ha funcionado.

Saludos

By Franz72

Supporter (8)

Franz72's picture

22-05-2020, 16:57

Esta noche pruebo,tranquilamente, lo que me comentais. Gracias!

Page 1/2
| 2