wtf is going on with my msx??

Por Z80-for-a-brain

Rookie (24)

imagem de Z80-for-a-brain

25-04-2005, 10:29

I have a little problem with my recently re-found msx. My disk with mbwave on it has some issues... I used diskmanager on my pc to create 2 disks, one dos 2 disk, and a disk with the mbwave program files on it. When I boot my msx to basic and do a "files" command, both disks show all the files, so no problems there.
But when I boot to dos and do a "dir" command, the dos disk shows all files like it should, but the mbwave disk only shows msxdos2.sys and command2.com and not the mbwave program files... switch back to basic and there they are again....

how can this be??

Entrar ou registrar-se para comentar

Por Z80-for-a-brain

Rookie (24)

imagem de Z80-for-a-brain

25-04-2005, 11:16

a little update:

tried it on one of my other msx-es too, and the same happens there, so I guess the problem is in the disk itself...

Por [D-Tail]

Ascended (8261)

imagem de [D-Tail]

25-04-2005, 13:20

You prolly got MBWAVE by extracting (with WinRAR) some archives. WinRAR has this stupid bug with the Archive attribute, so when you insert those files into a diskimage, DOS2 won't be able to read or see them. Try (re-)setting the archive bits afore putting the files into DiskManager.

Por Grauw

Ascended (10678)

imagem de Grauw

25-04-2005, 19:22

MSX has an attribute bit as well, but... I guess Diskmanager might not put them correctly on the MSX diskimage. Which would then actually be a bug in Diskmanager Smile.

Por Manuel

Ascended (19210)

imagem de Manuel

25-04-2005, 21:04

AFAIK the latest version of DiskManager has this fixed.
But hey, wrdsk rules Smile