MSX Monitor question

Por Samor

Prophet (2121)

imagem de Samor

29-07-2005, 09:11

My MSX monitor has started to produce a lot of noise lately, a static sound, it's becoming more and more now. I've had it before but then it suddenly stopped doing that and worked normally for 3 more years.
Does anyone here know what I'm talking about and can tell me what this is ?

Entrar ou registrar-se para comentar

Por ro

Scribe (4561)

imagem de ro

29-07-2005, 10:41

sound like you need to re-solder some prints, had that same prob on almost every monitor I ever owned.

Por flyguille

Prophet (3028)

imagem de flyguille

29-07-2005, 12:18

static noice???

it is like... a HIGH VOLTAGE escape? that sounds like a blow of electricity. If that is true in days with a lot of humidity it sounds worst!

Por Meits

Scribe (6473)

imagem de Meits

29-07-2005, 14:05

Had it as well... I still own the same monitor and it's not being repared... It happened to be dust in the high voltage part... Blew it away...

Por SKiLLa

Expert (97)

imagem de SKiLLa

30-07-2005, 16:14

Yes, you might try & clean it - vacuumcleaner perhaps ?
I've had it too sometimes, and even a good hit to the side of monitor could help.
If it only gets worse you'd better let an expert (like Repair-Bas) look at it ...

Por Samor

Prophet (2121)

imagem de Samor

30-07-2005, 20:09

thanks. I will try.
By the way, the speaker sound recently also became distorted, but it's not all the time. I don't know if it's related (either way I use a stereo set for sound rather than the monitor output anyway)...