SX-1+ Mini with MegaFlashRom SCC+ SD problem(s)

Página 5/9
1 | 2 | 3 | 4 | | 6 | 7 | 8 | 9

Por Wolverine_nl

Paragon (1158)

imagem de Wolverine_nl

06-11-2020, 12:50

@SkalTura,
If this works, I hope for you it does, then many have the solution for this instability issue. Keep us posted Wink

Por KdL

Paragon (1408)

imagem de KdL

07-11-2020, 13:19

SkalTura wrote:

Answer from Daniel:
[i]-We are using a 1K pullup on the RESET line. Originally the Zemmix and the OCM used 10K pullup as per recommendations of KdL (he published some fixes for existing Zemmix units). Maybe we need to reverse this change and fit a 10K resistor instead.

The original 1chipMSX uses 1K pull-up and not 10K pull-up. The voltage is +3.3V above the pull-ups. So this choice is not mine but the author of 1chipMSX. Here is the 1chipMSX scheme supplied for free in the CD-ROM with the device.

In my opinion the dc-dc converter can make a difference in terms of stability, so check that it is of excellent quality.

Por SkalTura

Champion (332)

imagem de SkalTura

08-11-2020, 13:41

KdL wrote:

In my opinion the dc-dc converter can make a difference in terms of stability, so check that it is of excellent quality.

You mean the DC-DC converters used in the board, or the main power going into the SX-1 ??
Because I used 3 different PSU's for testing, including a calibrated professional power supply with thick cable.

Por KdL

Paragon (1408)

imagem de KdL

09-11-2020, 03:21

I mean the DC-DC converter used in the board.

https://www.msx.org/news/en/hardware-patch-20200819-for-ocm-...

Por KdL

Paragon (1408)

imagem de KdL

09-11-2020, 11:15

Please be informed that DIX game is not yet supported by OCM-PLD firmware and a black screen will be displayed on all OCM machines. So it's useless to try that game.

Sometimes some unstable behaviors are due to custom firmware not thoroughly tested.
So, could you test the MFR with a Zemmix Neo / SX-1 firmware taken from my OCM-PLD Pack v3.8.1 and tell me how it goes? My Zemmix Neo firmware are interchangeable and very stable. They have been tested on machines from various manufacturers.

Por SjaaQ

Master (219)

imagem de SjaaQ

09-11-2020, 17:10

I think the SX1+ has OCM-PLD Pack v3.8 preinstalled. I have tried both firmware versions together with the MFRSCC+SD but did not came across any issues.

I was wondering why DIX does not work. I only can assume it is about the memory configuration or something. I was planning on debugging, buy maybe you already know why, KdL?

Por SkalTura

Champion (332)

imagem de SkalTura

10-11-2020, 07:21

KdL wrote:

Please be informed that DIX game is not yet supported by OCM-PLD firmware and a black screen will be displayed on all OCM machines. So it's useless to try that game.

Okay, clear...
Some other games don't work either, and strangely all the games that don't work are ASCII8 ROM's.
But on the other hand, some ASCII8 ROM's are working, so not sure why that is.
Anyway... let's focus on the boot problem first...

KdL wrote:

Sometimes some unstable behaviors are due to custom firmware not thoroughly tested.
So, could you test the MFR with a Zemmix Neo / SX-1 firmware taken from my OCM-PLD Pack v3.8.1 and tell me how it goes? My Zemmix Neo firmware are interchangeable and very stable. They have been tested on machines from various manufacturers.

No idea how to do this, zero experience with FPGA machines...
And I read somewhere that the firmware used in the SX1Mini+ is somewhat customized. Is the OCM-PLD firmware compatible with the SX1Mini+ as well, or only the normal SX-1 ?

Por KdL

Paragon (1408)

imagem de KdL

10-11-2020, 14:57

Looking at the photo of the pcb I think it is compatible but first ask 8bits4ever for confirmation.

Por KdL

Paragon (1408)

imagem de KdL

10-11-2020, 15:02

SjaaQ wrote:

I was wondering why DIX does not work. I only can assume it is about the memory configuration or something. I was planning on debugging, buy maybe you already know why, KdL?

No I haven't investigated...

Por SkalTura

Champion (332)

imagem de SkalTura

16-11-2020, 16:01

Checked the board under a microscope at work, and found some resistor arrays that had poor soldering.
One of them was the pull-up resistor array in the reset circuit, so I had good hopes, but unfortunately re-soldering these components didn't solve the problem.

Ordered parts to do the 10k pull-up resistors modification and the capacitor for power stability modification.
To be continued...

Página 5/9
1 | 2 | 3 | 4 | | 6 | 7 | 8 | 9