Nokia promoting emulation on their new N900 device, look MSX!

Página 2/6
1 | | 3 | 4 | 5 | 6

Por Manuel

Ascended (18721)

imagem de Manuel

28-01-2010, 12:43

((I've now started to reinstall the dev env... so I will probably give it another try as soon as I have some time...))

Por Manuel

Ascended (18721)

imagem de Manuel

28-01-2010, 23:58

OK, I'm building .deb packages now Smile I'll try to put them online as soon as I'm done, so you can give them a try.

Por jr

Champion (377)

imagem de jr

29-01-2010, 07:13

Alrighty just send the URL when you're done Wink It doesn't necessarily need to be a deb package, I can use a plain binary just as well.

Por FiXato

Scribe (1733)

imagem de FiXato

30-01-2010, 11:32

Looks like the video got pulled..

Por Manuel

Ascended (18721)

imagem de Manuel

30-01-2010, 14:17

OK, I put some untested preliminary packages on the openMSX site, temporarily. These are highly experimental and purely for testing!

C-BIOS (dependency): http://openmsx.sourceforge.net/temp/cbios_0.23-2_all.deb
openMSX:
http://openmsx.sourceforge.net/temp/openmsx-data_0.7.2-4_all.deb
http://openmsx.sourceforge.net/temp/openmsx_0.7.2-4_armel.deb

Please try to install them (I'm not sure what the best way is...) and tell me what happens :)
Note that I have not made any changes to the packages. The sources are as-is, i.e. how they are also in Debian.
Probably, it makes a lot of sense to add/adjust key mappings, so you can use the OSD menu. Let me know if you need instructions for that.

If you also want Catapult, let me know. I thought OSD menu would probably be more convenient than a separate launcher.

Por jr

Champion (377)

imagem de jr

30-01-2010, 20:27

Works like charm. Had to get TCL 8.5 first but that's easily cured with "apt-get install tcl8.5". It does leave some room for improvement though -- it's not running full screen nor full frame rate with default settings. I guess getting rid of the display composition (i.e. running full screen and telling the system we don't like composition) would give some performance boost. Anyway, very nice, me likes Cool

Por Manuel

Ascended (18721)

imagem de Manuel

30-01-2010, 22:15

Thanks for testing that, jr! Smile

Yes, you also need Tcl 8.5.

As I said, I didn't touch the default settings at all, so they're the same as on a PC.

We could supply a settings.xml file with settings that are non-default, but suitable for the N900. Could you experiment with settings?
See this overview for all of them: http://openmsx.sourceforge.net/manual/commands.html#settings
Interesting settings:
- resampler (try fast)
- special effects like scanline, blur, noise
- set fullscreen on (for your full screen)
- if you use fullscreen, you could even set the scale_factor to 1. That should make a huge difference. (It runs full frame rate for most stuff on the Dingoo with scale_factor_1.)

You can check the frame rate with the "toggle_fps" command, which will show a frame rate indicator. That indicator itself is quite CPU intensive though (you can tune it a bit in the file share/scripts/osd_widgets.tcl, change the .2 to .5 or 1 or so).

See also http://openmsx.sourceforge.net/manual/setup.html#tuningvarious for some more tips... (the frequency setting one can be ignored, I'm removing it from the manual now).

By the way, I have no idea how we can influence that composition stuff.

Por jr

Champion (377)

imagem de jr

03-02-2010, 14:28

Hmm, perhaps my short test was a bit too short Wink I don't seem to get the keyboard working which is making things a little bit difficult... is there any way to get the openmsx print out the key events it gets from the system? Tried to bind the "toggle console" to a number of keys without success. Another option is of course that the openmsx window is for some reason not receiving any keyboard input.

Por mth

Champion (505)

imagem de mth

03-02-2010, 17:40

You can set the openMSX setting "kbd_trace_key_presses" to "true".

Por Manuel

Ascended (18721)

imagem de Manuel

03-02-2010, 21:59

Ah, I completely forgot about that issue. There seems to be a bug in SDL: http://talk.maemo.org/showthread.php?t=31696
which can be worked around by not setting an icon. I'll try to prepare a new package which has this workaround.

Página 2/6
1 | | 3 | 4 | 5 | 6