Toshiba HX-10, not working.

Страница 1/3
| 2 | 3

By xriva

Supporter (5)

Аватар пользователя xriva

25-03-2016, 15:08

Hi, I'm a new member on this forum. I recently purchased a non working Toshiba HX-10 on EBay. When I power the machine on, all that is displayed is a black screen. I checked the caps lock light and it's not working, neither do I get any sound when I press Ctrl-G. The voltages are all present and correct on all of the chips, I have tested the clock signal on the Z80 and that is good. There is activity on the address and data lines. I tested the crystal on the TMS9929 that is good also. I dumped the ROM to a file and tested it on OpenMSX, it is also O.K Then I turned my attention to the DRAM chips, the /CAS line is permanently high. This line is connected to pin 5 of the TCX-1007 chip (IC25). I have spent a lot of time on google, trying to find some info on these chips, to no avail. Does anybody here have any info/datasheet on these chips? Also, I know this has been asked a thousand times before, but does anybody know where to get a schematic for the HX-10? Any addition thoughts or insight that any of you have would be greatly appreciated.

Для того, чтобы оставить комментарий, необходимо регистрация или !login

By zPasi

Champion (499)

Аватар пользователя zPasi

25-03-2016, 17:17

xriva wrote:

Then I turned my attention to the DRAM chips, the /CAS line is permanently high. This line is connected to pin 5 of the TCX-1007 chip (IC25).

TCX-1007 is not IC25 but IC15 Smile
I think the fault is more likely somewhere else than that IC, maybe some dram chip(s) failed. But what do I know anyway...

However, I found a previous thread about a same kind of problem https://www.msx.org/forum/msx-talk/hardware/toshiba-hx-10-bl...

From that thread:

RetroTechie wrote:

-> That 64-pin IC (TCX-1007) is some sort of custom IC / MSX engine. I'm guessing 'S3527 minus the PSG' (note absence of a 8255 on the board).

"MSX engine" - that I would have guessed too. It probably works alright but it may help to know what IC it is, when tracing the fault.

By xriva

Supporter (5)

Аватар пользователя xriva

25-03-2016, 18:03

My bad, I mistakenly looked at the id for the PSG under TCX-1007. https://www.msx.org/sites/all/themes/mrc2k11/img/smileys/smi...

Yes, I suppose if /CAS on one of the dram chips is stuck high, it might hold all of them high.

Thanks for the link to the previous thread, I have found a datasheet for the Yamaha S3527 it may prove helpful in mapping out the TCX-1007.

I have checked the pins of TCX-1007 with my logic probe and there isn't much activity on the pins on the lower side of the chip. I think my next move is to trace all the connections on TCX-1007 to determine what is supposed to be happening.

By Alexey

Guardian (3163)

Аватар пользователя Alexey

25-03-2016, 19:58

Do you have a cartridge with an external RAM? Try to find it and insert into slot A. See what happens. Do any game cartridges work?

By xriva

Supporter (5)

Аватар пользователя xriva

25-03-2016, 21:18

Alexey wrote:

Do you have a cartridge with an external RAM? Try to find it and insert into slot A. See what happens. Do any game cartridges work?

I haven't got any cartridges at the moment, this is my first MSX. I will look out for one on ebay, which ones will have external RAM?

By Alexey

Guardian (3163)

Аватар пользователя Alexey

25-03-2016, 21:22

I think this is the best one. I have one of those. The price is reasonable.

http://www.ebsoft.fr/shop/en/home/35-musical-memory-mapper.html

By xriva

Supporter (5)

Аватар пользователя xriva

25-03-2016, 21:39

Alexey wrote:

I think this is the best one. I have one of those. The price is reasonable.

http://www.ebsoft.fr/shop/en/home/35-musical-memory-mapper.html

O.K I will get one to try.

By xriva

Supporter (5)

Аватар пользователя xriva

31-03-2016, 11:43

O.K, quick update, made myself an arduino based DRAM tester and tested all the D4164C chips(IC7 - IC14) and it turns out two of them were bad (IC8 and IC12). I have bought some new ones and put in chip sockets for all the DRAM.

Now all is well and I have a perfectly functioning HX-10, thanks for all the help and suggestions.

By Wild_Penguin

Hero (641)

Аватар пользователя Wild_Penguin

31-03-2016, 14:11

Ooo, Nice!

It seems quite common that these old machines get a memory fault.

By llopis

Resident (53)

Аватар пользователя llopis

18-01-2019, 23:45

I know I'm resurrecting a really old thread, but I have an HX 10 with the exact same problem: Black screen, no CAPs light.

It had a bad ROM which I replaced with an EPROM, but /CAS is always high. I socked and replaced all the RAM ICs (one of them was faulty) but I'm still with high /CAS and black screen.

Since there doesn't seem to be a publicly available schematic for this model, I'm kind of at a loss. The /CAS signal is produced by the TCX-1007, but I'm sure a lot of the glue logic chips around it contribute to combine signals. Maybe one of those is faulty and causing /CAS to be always high.

Any ideas what else I could check?

Thanks.

By gdx

Enlighted (4637)

Аватар пользователя gdx

19-01-2019, 01:25

Capacitors and -5V.

Страница 1/3
| 2 | 3